summaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2018-09-27 17:35:20 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2018-09-28 16:01:32 +0000
commit3b2111ffe4a7a004479445f857e0b4cf09694c7a (patch)
treeada650bfee88c7aaf93a5b7330cf0b5c4d7ca7a7 /meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
parentbd047dd78bac07451375e19f03b5f936efcf5f03 (diff)
4A: delay service startup as a workaround to SPEC-1762/SPEC-1763 (temp workaround)
This patch introduces a wait loop before starting the 4A binder: * wait for bluetooth module to be loaded * wait for bluetooth controller to be up & running * wait for bluetooth manager to be initialized Then 4A can start with BT-audio support. If no BT controller is detected in 5secondes, the loop exits and 4A doesn't initialize BT-Audio Bug-AGL: SPEC-1762, SPEC-1763 Change-Id: Ibe851dee871d183511c7bca03411b35ed023f422 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb')
-rw-r--r--meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
index 63d2bdb5..78cb2e7f 100644
--- a/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
+++ b/meta-audio-4a-framework/recipes-multimedia/agl-service-audio-4a/agl-service-audio-4a_git.bb
@@ -37,8 +37,22 @@ sed -i -e 's|/usr/bin/afb-daemon\>|& --ldpath=/usr/libexec/agl/4a-alsa-core/lib:
# binder name matters: it must match "afbd-4a-*" => the config file (controller json file) that will be searched will be "policy-4a-*.json"
sed -i -e 's|--name afbd-agl-\(.*\)|--name afbd-4a-\1|' $svcfile
+# workaround for SPEC-1762
+sed -i -e 's|/usr/bin/afb-daemon\>|/usr/bin/4a_wait_bt.sh &|' $svcfile
+
echo "-- TMP 4A INSTALL FIX END"
EOF
chmod a+x ${D}/${sysconfdir}/agl-postinsts/99_4A_service_patch.sh
}
+
+##############################################
+# workaround for SPEC-1762/SPEC-1763
+RDEPENDS_${PN} += "bash"
+SRC_URI += "file://4a_wait_bt.sh"
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/4a_wait_bt.sh ${D}${bindir}/
+}
+#
+##############################################