summaryrefslogtreecommitdiffstats
path: root/meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-11-14 14:34:39 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-11-15 16:36:57 +0100
commitc595090c2005106c71c2015ed47aa44e27ef6983 (patch)
tree1b9b8253960047f2322ba30fc8e837a56b3418d7 /meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb
parentbf5edb1f6e62c8e66efcc7937044eac06744a0df (diff)
Add agl-service-unicens recipes
* Add agl-service-unicens and 4a-hal-unicens to packagegroup-agl-audio recipes. * Add mxml recipes (dependency of agl-service-unicens). origin: https://github.com/schnitzeltony/meta-qt5-extra/blob/master/recipes-support/mxml/mxml_2.10.bb Change-Id: Ib62f0a3af74cd99bdf00d120b232c84be49875d8 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb')
-rw-r--r--meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb b/meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb
new file mode 100644
index 00000000..bca248b6
--- /dev/null
+++ b/meta-audio-4a-framework/recipes-support/mxml/mxml_2.10.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Mini-XML is a small XML library"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6ba38606d63bb042c5d8cfee182e120"
+
+DEPENDS = ""
+
+SRC_URI = " \
+ https://github.com/michaelrsweet/mxml/releases/download/release-${PV}/${BPN}-${PV}.tar.gz \
+ file://0001-avoid-testing-library-in-cross-environments.patch \
+ file://0002-don-t-loose-our-LDFLAGS.patch \
+"
+SRC_URI[md5sum] = "8804c961a24500a95690ef287d150abe"
+SRC_URI[sha256sum] = "267ff58b64ddc767170d71dab0c729c06f45e1df9a9b6f75180b564f09767891"
+
+inherit autotools-brokensep
+
+EXTRA_AUTORECONF += "--exclude=autoheader"
+
+do_install() {
+ install -d ${D}${includedir}
+ install -m 644 mxml.h ${D}${includedir}
+
+ install -d ${D}${libdir}/pkgconfig
+ install -m 644 libmxml.so.1.5 ${D}${libdir}
+ ln -s libmxml.so.1.5 ${D}${libdir}/libmxml.so
+ ln -s libmxml.so.1.5 ${D}${libdir}/libmxml.so.1
+
+ install mxml.pc ${D}${libdir}/pkgconfig
+
+ # Remove useless rpath
+ chrpath -d ${D}${libdir}/libmxml.so.1.5
+
+}