summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/conf
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-02-08 10:53:36 -0500
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-04-09 18:28:28 +0200
commitce687dbdb3a56d42a042240509b38dbd5abdb038 (patch)
treecabcbdb762805518f62424562212d2ddcca431fa /meta-egvirt/conf
parent4ecb137abc1e72f71a3aa3d59ff323908d1f4e51 (diff)
Upgrade to thud
Changes include: - Add LAYERSERIES_COMPAT definitions to layer.conf files - Disable pulseaudio-module-4a-client for now as it does not compile against PulseAudio 12.x - Remove meta-audio-4a-framework/recipes-devtools/python/python3-websockets_4.0.1.bb as it is superseded by upstream - Add OECMAKE_GENERATOR = "Unix Makefiles" to 4a-alsa-core, 4a-hal-generic, 4a-hal-unicens, and 4a-softmixer recipes for now to work around CMake+ninja issue - Remove alsa 1.1.6 recipes from meta-audio-4a-framework/recipes-multimedia/alsa as they are superseded by upstream. Local changes to the alsa-plugins recipe have been implemented in a bbappend. Known issues: - pulseaudio-module-4a-client has been disabled - CMake+ninja issue in cmake-apps-module has been worked around with OECMAKE_GENERATOR Bug-AGL: SPEC-1837 Change-Id: I5355e9f74e2385a093ca21cda5bd52a80e1a6e67 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-egvirt/conf')
-rw-r--r--meta-egvirt/conf/layer.conf1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-egvirt/conf/layer.conf b/meta-egvirt/conf/layer.conf
index 4462a42c..88c8a3bd 100644
--- a/meta-egvirt/conf/layer.conf
+++ b/meta-egvirt/conf/layer.conf
@@ -11,6 +11,7 @@ BBFILE_PRIORITY_egvirt = "6"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_egvirt = "1"
+LAYERSERIES_COMPAT_egvirt = "thud"
LAYERDEPENDS_egvirt = "core"
#0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
SUMMARY = "KUKSA.val CAN provider configuration for AGL demos"

LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"

SRC_URI = "file://config.ini \
           file://can-provider.token \
           file://dbc_default_values.json \
           file://can-dev-helper.conf \
"

S = "${WORKDIR}"

inherit allarch systemd

do_compile[noexec] = "1"

do_install() {
    install -d ${D}${sysconfdir}/kuksa-can-provider
    install -m 0644 ${WORKDIR}/config.ini ${D}${sysconfdir}/kuksa-can-provider/
    install -m 0644 ${WORKDIR}/can-provider.token ${D}${sysconfdir}/kuksa-can-provider/
    install -m 0644 ${WORKDIR}/dbc_default_values.json ${D}${sysconfdir}/kuksa-can-provider/
    install -d ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d
    install -m 0644 ${WORKDIR}/can-dev-helper.conf ${D}${systemd_system_unitdir}/kuksa-can-provider.service.d/
}

FILES:${PN} += "${systemd_system_unitdir}"

RDEPENDS:${PN} += "kuksa-can-provider agl-dbc can-dev-helper"
RPROVIDES:${PN} += "kuksa-can-provider-conf"