summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/dynamic-layers/raspberrypi
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2024-10-03 14:54:11 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-22 12:22:20 +0000
commit9f40106ff471d77ecd978d4b0b48f560a591420e (patch)
treec60b70eadecf2f5741cdc281a064d31ae3172e66 /meta-egvirt/dynamic-layers/raspberrypi
parentd9b03f2d9b945805f56dfe3eb526264c68747d6f (diff)
Add dynamic layer for raspberrypi and rcar-gen3
Updates [v2]: It backports the virtio-sound module for rcar-gen3 and enables virtio-sound, virtio-can, virtio-input, virtio-console, virtio-loopback for both cases. Updates [v1]: Add linux-renesas kernel configuration Specifically this commit creates a new directory 'linux-renesas' for configuring the required modules to be loaded by that kernel. It is also backports the virtio-sound module and enables virtio-sound, virtio-can, virtio-input, virtio-console and virtio-loopback. Virtio-sound module sources: Source: https://lore.kernel.org/alsa-devel/20210302164709.3142702-1-anton.yakovlev@opensynergy.com Bug-AGL: SPEC-4966 Change-Id: Ie143e690695a526958e07a66ba481887b2e4a248 Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/dynamic-layers/raspberrypi')
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg6
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_can.cfg1
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_input.cfg2
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_loopback.cfg7
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_sound.cfg6
-rw-r--r--meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend10
6 files changed, 32 insertions, 0 deletions
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg
new file mode 100644
index 00000000..82ff9ea1
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/enable-virtio.cfg
@@ -0,0 +1,6 @@
+CONFIG_VIRTIO=y
+CONFIG_VIRTIO_MMIO=y
+CONFIG_VIRTIO_BLK=y
+CONFIG_VIRTIO_BLK_SCSI=y
+CONFIG_VIRTIO_PCI=y
+CONFIG_VIRTIO_PCI_LEGACY=y
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_can.cfg b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_can.cfg
new file mode 100644
index 00000000..302e4ddb
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_can.cfg
@@ -0,0 +1 @@
+CONFIG_CAN_DEV=m
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_input.cfg b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_input.cfg
new file mode 100644
index 00000000..55e65d1b
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_input.cfg
@@ -0,0 +1,2 @@
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_loopback.cfg b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_loopback.cfg
new file mode 100644
index 00000000..51c8a2d3
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_loopback.cfg
@@ -0,0 +1,7 @@
+CONFIG_HW_RANDOM_VIRTIO=m
+CONFIG_VIRTIO_INPUT=m
+CONFIG_VIRTIO_CAN=m
+CONFIG_VIRTIO_GPIO=m
+CONFIG_VIRTIO_CONSOLE=m
+CONFIG_VIRTIO_BLK=m
+CONFIG_SND_VIRTIO=m
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_sound.cfg b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_sound.cfg
new file mode 100644
index 00000000..2e9486e2
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-common/virtio_sound.cfg
@@ -0,0 +1,6 @@
+CONFIG_SND=y
+CONFIG_SOUND=y
+CONFIG_SND_TIMER=y
+CONFIG_SND_PCM=y
+CONFIG_SND_JACK=y
+CONFIG_SND_JACK_INPUT_DEV=y
diff --git a/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
new file mode 100644
index 00000000..1de2965f
--- /dev/null
+++ b/meta-egvirt/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -0,0 +1,10 @@
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/linux-common/:"
+
+SRC_URI:append = " \
+ file://enable-virtio.cfg \
+ file://virtio_can.cfg \
+ file://virtio_input.cfg \
+ file://virtio_loopback.cfg \
+ file://virtio_sound.cfg \
+"