summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2024-10-03 11:00:30 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-07 16:40:10 +0000
commit0b813fa1224e4c31caf4dbab0bd8146c4d038f4e (patch)
treed65dcbb60673cd1a553e469c87316bf5cff90481 /meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
parent70c6b997f65a4ea87003b7dcb3c282c590c6cec2 (diff)
Update vhost-device-can and align it with rust-vmm implementation
[v2]: Remove recipe for socketcan-rs lib. Update vhost-device-can recipe to clone and be built with a selected version of socketcan-rs. [v1]: Update vhost-device-can device and align it with the vhost-device upstream implementation (commit: 42fa1204ec) - https://github.com/rust-vmm/vhost-device/tree/main/staging/vhost-device-can Bug-AGL: SPEC-4966 Change-Id: I9b7f5cb5d84c77198bc0c8b8cebc256fb5df6926 Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml')
-rw-r--r--meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml b/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
deleted file mode 100644
index 08d012c2..00000000
--- a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can-0.1.0/Cargo.toml
+++ /dev/null
@@ -1,35 +0,0 @@
-[package]
-name = "vhost-device-can"
-version = "0.0.1"
-authors = ["Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>"]
-description = "vhost can backend device"
-repository = "https://github.com/rust-vmm/vhost-device"
-readme = "README.md"
-keywords = ["can", "vhost", "virt", "backend"]
-license = "Apache-2.0 OR BSD-3-Clause"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[features]
-xen = ["vm-memory/xen", "vhost/xen", "vhost-user-backend/xen"]
-
-[dependencies]
-queues = "1.0.2"
-socketcan = "3.2"
-clap = { version = "4.2.5", features = ["derive"] }
-env_logger = "0.10"
-libc = "0.2"
-log = "0.4"
-thiserror = "1.0"
-vhost = { version = "0.8", features = ["vhost-user-slave"] }
-vhost-user-backend = "0.10"
-virtio-bindings = "0.2.1"
-virtio-queue = "0.9"
-vm-memory = "0.12"
-vmm-sys-util = "0.11"
-
-[dev-dependencies]
-assert_matches = "1.5"
-virtio-queue = { version = "0.9", features = ["test-utils"] }
-vm-memory = { version = "0.12", features = ["backend-mmap", "backend-atomic"] }