summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2024-10-03 11:00:30 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-11-07 16:40:10 +0000
commit0b813fa1224e4c31caf4dbab0bd8146c4d038f4e (patch)
treed65dcbb60673cd1a553e469c87316bf5cff90481 /meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb
parent70c6b997f65a4ea87003b7dcb3c282c590c6cec2 (diff)
Update vhost-device-can and align it with rust-vmm implementation
[v2]: Remove recipe for socketcan-rs lib. Update vhost-device-can recipe to clone and be built with a selected version of socketcan-rs. [v1]: Update vhost-device-can device and align it with the vhost-device upstream implementation (commit: 42fa1204ec) - https://github.com/rust-vmm/vhost-device/tree/main/staging/vhost-device-can Bug-AGL: SPEC-4966 Change-Id: I9b7f5cb5d84c77198bc0c8b8cebc256fb5df6926 Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb')
-rw-r--r--meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb20
1 files changed, 17 insertions, 3 deletions
diff --git a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb b/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb
index 4db8ebea..e54e06f6 100644
--- a/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb
+++ b/meta-egvirt/recipes-extended/vhost-device-can/vhost-device-can_0.1.0.bb
@@ -2,10 +2,16 @@ SUMMARY = "vhost CAN backend device"
DESCRIPTION = "A vhost-user backend that emulates a VirtIO CAN device"
HOMEPAGE = "https://gerrit.automotivelinux.org"
-FILESEXTRAPATHS:prepend := "${THISDIR}:"
-EXTRAPATHS:prepend := "${THISDIR}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
+EXTRAPATHS:prepend := "${THISDIR}/files:"
-SRC_URI = " file://. "
+SRC_URI = "\
+ file://vhost-device-can-0.1.0/ \
+ git://github.com/socketcan-rs/socketcan-rs.git;protocol=https;branch=master \
+"
+SRCREV = "f004ee91e142a37fea36c5d719a57852c7076e87"
+
+SRC_URI[sha256sum] = "f8a0826ee8082e8f6f3549eaa86406ee22187a5d1e3ad940d3788b072cf18991"
LICENSE = "Apache-2.0 | BSD-3-Clause"
LIC_FILES_CHKSUM = "\
@@ -13,7 +19,15 @@ LIC_FILES_CHKSUM = "\
file://LICENSE-BSD-3-Clause;md5=2489db1359f496fff34bd393df63947e \
"
+RDEPENDS:${PN}:append = " can-utils"
+
inherit cargo
inherit pkgconfig
+inherit cargo-update-recipe-crates
include vhost-device-can-crates.inc
+include socketcan-crates.inc
+
+CARGO_BUILD_FLAGS = "-v --offline --target ${RUST_HOST_SYS} ${BUILD_MODE} --manifest-path=${CARGO_MANIFEST_PATH}"
+
+S = "${WORKDIR}/vhost-device-can-0.1.0"