summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb
diff options
context:
space:
mode:
authorTimos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>2024-10-03 11:05:08 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-10-22 12:21:45 +0000
commitc5a365cef2d7c39c5679d947b38f71091b5427bf (patch)
tree37a52e365020ab890c8c6716727ae3684b8758f7 /meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb
parent8e65c45718d4e628092ba90731fe6eaef0d5bca0 (diff)
Add vhost-device-input (rust implementation)
Bug-AGL: SPEC-4966 Change-Id: Ice39bb44594802970618bf0a54f4ec633be83240 Signed-off-by: Timos Ampelikiotis <t.ampelikiotis@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb')
-rw-r--r--meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb b/meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb
new file mode 100644
index 00000000..c1ca4b5a
--- /dev/null
+++ b/meta-egvirt/recipes-extended/vhost-device-input/vhost-device-input_0.1.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "vhost-user input backend device"
+DESCRIPTION = "A vhost-user backend that emulates a VirtIO input device"
+HOMEPAGE = "https://github.com/rust-vmm/vhost-device"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE-APACHE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://LICENSE-BSD-3-Clause;md5=2489db1359f496fff34bd393df63947e \
+"
+
+SRC_URI += "git://github.com/rust-vmm/vhost-device.git;protocol=http;branch=main"
+SRCREV = "cec57c943354e938cde08ba984f8b1efb6cfa99a"
+
+inherit cargo
+inherit pkgconfig
+inherit cargo-update-recipe-crates
+
+S = "${WORKDIR}/git"
+
+CARGO_BUILD_FLAGS = "--bin vhost-device-input -v --offline --target ${RUST_HOST_SYS} ${BUILD_MODE} --manifest-path=${CARGO_MANIFEST_PATH}"
+
+include vhost-device-input-crates.inc