summaryrefslogtreecommitdiffstats
path: root/meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb
diff options
context:
space:
mode:
authorMichele Paolino <m.paolino@virtualopensystems.com>2024-02-29 15:22:17 +0000
committerMichele Paolino <m.paolino@virtualopensystems.com>2024-05-13 14:26:00 +0000
commita22aad5cfd2c4bf5d5c0fdf81c830e78c7456848 (patch)
tree58d4b74c5a126d8a92a9a5109f87f133bc4234d0 /meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb
parentc7c181b3986803e49844e1e371643b6545e8681e (diff)
vhost-device-sound recipe
This recipe compiles and installs the rust vhost-device-sound device to AGL. It works with scarthgap (for now tested with qemux86) Bug-AGL: SPEC-4966 Change-Id: I6acdbeabfb4e0b2d236d37ea62af973645f87b99 Signed-off-by: Michele Paolino <m.paolino@virtualopensystems.com>
Diffstat (limited to 'meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb')
-rw-r--r--meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb b/meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb
new file mode 100644
index 00000000..e64190ad
--- /dev/null
+++ b/meta-egvirt/recipes-extended/vhost-device-sound/vhost-device-sound_0.1.0.bb
@@ -0,0 +1,17 @@
+SUMMARY = "vhost-device sound"
+DESCRIPTION = "A virtio-sound device using the vhost-user protocol."
+HOMEPAGE = "https://github.com/rust-vmm/vhost-device"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = " \
+ file://LICENSE-APACHE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
+ file://LICENSE-BSD-3-Clause;md5=2489db1359f496fff34bd393df63947e \
+"
+SRC_URI += "crate://crates.io/vhost-device-sound/0.1.0"
+SRC_URI[vhost-device-sound-0.1.0.sha256sum] = "8d89731cfe36eb3b57b6eec55b7ed0f79e34b34274fd4f672035b548417c7f09"
+
+DEPENDS = "alsa-lib pipewire clang-native"
+
+inherit cargo
+inherit pkgconfig
+include vhost-device-sound-crates.inc
+