summaryrefslogtreecommitdiffstats
path: root/meta-hmi-framework/recipes-demo-hmi
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-09-29 21:47:25 +0900
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-10-12 16:52:13 +0200
commit7d7fe0e26af1a27b7a3e2256f6ef48965b3239ed (patch)
treea4c24b048969636d0522e939770d21c0fde83e7a /meta-hmi-framework/recipes-demo-hmi
parent9a58b814a852f6b761b22f5c8f41cb8489dae628 (diff)
Add recipes for new hmi fweel_4.99.1eel/4.99.14.99.1
Add recipesc for agl-service-windowmanager-2017, agl-service-soundmanager-2017, agl-service-homescreen-2017 and homescreen-2017. [Patch Sets 2] Modify homescreen-2017_git.bb to use aglwgt make package. [Patch Sets 3] Modify agl-service-windowmanager-2017_git.bb to use aglwgt make package. Modify agl-service-soundmanager-2017_git.bb to use aglwgt make package. [Patch Sets 4] Modify agl-service-homescreen-2017_git.bb to use aglwgt make package. [Patch Sets 5] (jsmoeller) Modify layer and add packagegroup containing the required packages. Modify feature name to be agl-hmi-framework to be consistent in naming Mofify local.conf.inc to set DISTRO_FEATURES flag instead of setting IMAGE_INSTALL. Change-Id: Iac998b5c9ed519649c8c367e97a5aa31c6140c26 Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-hmi-framework/recipes-demo-hmi')
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb25
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb15
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb
new file mode 100644
index 00000000..a07bc1dc
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/agl-service-homescreen-2017/agl-service-homescreen-2017_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Homescreen binding and client library for application"
+DESCRIPTION = "Homescreen 2017 is the binding library"
+HOMEPAGE = "https://git.automotivelinux.org/apps/agl-service-homescreen-2017"
+S = "${WORKDIR}/git"
+SECTION = "HMI"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+inherit cmake aglwgt
+DEPENDS = "dbus glib-2.0 af-binder json-c"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-homescreen-2017;protocol=https;branch=master"
+SRCREV = "e0163d2b8daae98ced81f4bc737998c00858e771"
+
+do_install_append() {
+ install -d ${D}/usr/lib/pkgconfig
+ install -m 0644 ${B}/homescreen.pc ${D}/usr/lib/pkgconfig
+
+ install -d ${D}/usr/include
+ install -m 0644 ${S}/include/libhomescreen.hpp ${D}/usr/include
+
+ install -d ${D}/usr/lib
+ install -m 0755 ${B}/libhomescreen/libhomescreen.so ${D}/usr/lib/libhomescreen.so.0.1
+ ln -sf libhomescreen.so.0.1 ${D}/usr/lib/libhomescreen.so
+}
diff --git a/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
new file mode 100644
index 00000000..f13a9d16
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/homescreen-2017/homescreen-2017_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "AGL Home Screen 2017 Application"
+DESCRIPTION = "AGL Home Screen 2017 Application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/gitweb?p=staging/homescreen-2017.git"
+S = "${WORKDIR}/git/"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+inherit qmake5 systemd pkgconfig aglwgt
+DEPENDS = " qtbase qtdeclarative qtquickcontrols2 pulseaudio agl-service-homescreen-2017 agl-service-windowmanager-2017"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/homescreen-2017;protocol=https;branch=master"
+SRCREV = "381755e4686a08e766316aaf40e8fdfa202d48d4"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"