summaryrefslogtreecommitdiffstats
path: root/meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-01-17 19:14:37 -0500
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-02-08 15:25:25 +0100
commitea65c2ebaacdf50eba4f33a94e6151274b5d5c8f (patch)
treef2444a5d72af60186f667d0118d6562b89d5c80c /meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb
parent61aee64f7b4fc1c78dd8a585a79ec9e4e7aa820a (diff)
agl-service-windowmanager: add weston-ready systemd dependencyguppy_7.0.0guppy/7.0.07.0.0
Add installation of systemd over-ride configuration that adds a dependency on weston-ready to ensure that the windowmanager and its dependencies start after weston is actually initialized. In testing, this seems to resolve the issue of homescreen and launcher failing to start in situations such as when using MOST audio and/or the gst-record feature in Weston. Bug-AGL: SPEC-2115 Change-Id: Id15045357f30d3f447037026d0ab960ae2569d69 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 7650fff17bd502e80feb28dc9bf5927bc5ecf52c) Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb')
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb
index a7dd894a..d80106c9 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager/agl-service-windowmanager_git.bb
@@ -13,10 +13,24 @@ DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
inherit cmake aglwgt
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager;protocol=https;branch=${AGL_BRANCH} \
+ file://weston-ready.conf \
+"
SRCREV = "fb861c2f05e5f49f4009d0d7c91101259f904f1d"
PV = "1.0+git${SRCPV}"
S = "${WORKDIR}/git"
#If you would like to output log, uncomment out
EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "
+
+do_install_append() {
+ # Install systemd over-ride that adds a dependency on weston-ready
+ # to ensure that the windowmanager and its dependencies start after
+ # weston is actually initialized.
+ install -d ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+ install -m 0644 ${WORKDIR}/weston-ready.conf ${D}${sysconfdir}/systemd/system/afm-api-windowmanager@.service.d
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"
+
+REDEPENDS_${PN} += "weston-ready"