summaryrefslogtreecommitdiffstats
path: root/meta-hmi-framework/recipes-graphics
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-02 11:56:53 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-11-02 11:56:56 +0100
commit8e7e0ea31dcec482e10c5f153b51f01c6576f281 (patch)
tree0fc754b7f8fcc085c8b34ca2c0fc9fc1c56e15f1 /meta-hmi-framework/recipes-graphics
parentb94ec6173a2e28507522e7ece1fbb3fe8e06245d (diff)
Recipe style fixes in meta-hmi-framework
This change applies the standard bitbake recipe layout, especially it fixes: - DEPENDS before inherit (as we might DEPENDS += in the inherit !) - 'S =' below SRC_URI (style nitpick) - DESCRIPTION being present These changes are just 'formatting' but worst case we see a difference in DEPENDS due to the corrected ordering. Change-Id: I9c82114c4f4e86a59e73e3ebcdc063b2ed6bd4f1 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-hmi-framework/recipes-graphics')
-rw-r--r--meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb15
-rw-r--r--meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb8
2 files changed, 14 insertions, 9 deletions
diff --git a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
index a9fcaa67..e9faa594 100644
--- a/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
+++ b/meta-hmi-framework/recipes-graphics/agl-service-windowmanager-2017/agl-service-windowmanager-2017_git.bb
@@ -1,19 +1,22 @@
SUMMARY = "Window Manager service binding for applications"
-DESCRIPTION = "Window Manager 2017 is the service binding for controlling rendering rights \
- Applications requests to render itself, then Window Manager check policy and notify layout to respective applications \
- "
+DESCRIPTION = "Window Manager 2017 is the service binding for controlling \
+ rendering rights. Applications request to render itself, \
+ then Window Manager checks the policy and notifies the \
+ layout to the respective applications \
+ "
HOMEPAGE = "https://wiki.automotivelinux.org/windowmanager"
-SECTION = "graphics"
+SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93 \
file://LICENSE.MIT;md5=a7514fe5664902e337bd8a4443d8f348"
+
DEPENDS = "af-binder json-c wayland wayland-ivi-extension wayland-native"
+inherit cmake aglwgt
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-windowmanager-2017;protocol=https;branch=master"
SRCREV = "3772dc5dc1b89ac101134d02529bde7185e68948"
S = "${WORKDIR}/git"
-inherit cmake aglwgt
-
#If you would like to output log, uncomment out
EXTRA_OECMAKE_append_agl-devel = " -DENABLE_DEBUG_OUTPUT=ON "
diff --git a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
index d291ef81..50bbe979 100644
--- a/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
+++ b/meta-hmi-framework/recipes-graphics/libwindowmanager/libwindowmanager_git.bb
@@ -1,12 +1,14 @@
SUMMARY = "Window Manager client library for applications"
-SECTION = "graphics"
+DESCRIPTION = "Window Manager client library for application built with recipe"
+SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
DEPENDS = "af-binder json-c"
RDEPENDS_${PN} = "agl-service-windowmanager-2017"
+inherit cmake
+
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/libwindowmanager.git;protocol=https;branch=master"
SRCREV = "71d3c9ee49ece6063ea93090b3661df6a90dd1de"
S = "${WORKDIR}/git"
-
-inherit cmake