summaryrefslogtreecommitdiffstats
path: root/meta-hmi-framework
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-06 11:14:02 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-07-06 11:14:02 +0000
commitf55a473aed7a16a2682eaeb2343453f82b9d8240 (patch)
tree21edf5926df62f51a60878ca9eed99b24235e26a /meta-hmi-framework
parent3e9a0a7b932727b851a6090326ce58999f8cdeb2 (diff)
parent35327849b830f6b6328aa75119dd8f6e08fcc100 (diff)
Merge "Add launcher recipes and add into packagegroup"
Diffstat (limited to 'meta-hmi-framework')
-rw-r--r--meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb25
-rw-r--r--meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb b/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb
new file mode 100644
index 00000000..9d78ff1a
--- /dev/null
+++ b/meta-hmi-framework/recipes-demo-hmi/launcher/launcher_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "AGL Launcher Application"
+DESCRIPTION = "AGL Launcher Application build with recipe method"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/launcher"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://launcher/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+ qtbase \
+ qtdeclarative \
+ qtquickcontrols2 \
+ qtwebsockets \
+ qlibwindowmanager \
+ qlibhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/launcher;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
diff --git a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
index 61af066d..516e5230 100644
--- a/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
+++ b/meta-hmi-framework/recipes-platform/packagegroups/packagegroup-hmi-framework.bb
@@ -15,4 +15,5 @@ RDEPENDS_${PN} += " \
qlibhomescreen \
runxdg \
hmi-debug \
+ launcher \
"