summaryrefslogtreecommitdiffstats
path: root/meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2018-12-20 19:47:17 +0100
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-01-15 11:25:41 +0000
commit4a6461a2a52c842efe1b9df668809385ab657b2d (patch)
treefbad7c0fe8731c4228fd264c3a40d50814ab89a2 /meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb
parent9431585b5e02eec40e6644b58909fc6c7095cbe3 (diff)
Integrate Chromium and WAM recipes.
Create a new layer called meta-html5-framework. It contains the following recipes: * chromium68 to build the browser shared library and browser code. * chromium-browser-service for the browser widget. * wam for the web application manager. * wam-tinyproxy is a direct dependency of wam. Defines a new packagegroup, which is added to the agl-demo-platform image in case agl-html5-framework is configured as a feature. Bug-AGL: SPEC-1885 Change-Id: I39f01ab09e198cd139e95ff3c784af563b54329b Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com> (cherry picked from commit 19e71462fc44093c6f9046e60c72adeedfca7858)
Diffstat (limited to 'meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb')
-rw-r--r--meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb b/meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb
new file mode 100644
index 00000000..5bb028b9
--- /dev/null
+++ b/meta-html5-framework/recipes-wam/chromium/chromium-browser-service.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Chromium browser widget"
+DESCRIPTION = "Wgt packaging for running chromium installed browser"
+HOMEPAGE = "https://webosose.org"
+SECTION = "apps"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "gitsm://github.com/webosose/${PN}.git;branch=flounder;protocol=https"
+SRCREV = "b1d34892e70aee9d1c8f4602c4db28847825fb1a"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+#build-time dependencies
+DEPENDS += "af-binder af-main-native chromium68"
+
+inherit cmake aglwgt
+
+RDEPENDS_${PN} += "chromium68-browser runxdg"