summaryrefslogtreecommitdiffstats
path: root/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2019-06-29 13:49:30 +0200
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-06-29 13:49:30 +0200
commit74bbed9133fa19df7ffe61a4c937820f4a3ae49e (patch)
tree6e9ace521761817ce368d31d7d662609c9eaa293 /meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
parent0f01dcc26aa0b9eecb8c04fbce42999beecde302 (diff)
chromium68: fix aarch64 link issuehalibut_7.99.2halibut/7.99.27.99.2
Backport upstream patch: https://chromium-review.googlesource.com/c/chromium/third_party/ffmpeg/+/1390286 Fix this error when linking libcbe.so: obj/third_party/ffmpeg/ffmpeg_internal/ autorename_libavcodec_aarch64_h264idct_neon.o: relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol `ff_h264_idct8_add_neon' which may bind externally can not be used when making a shared object; recompile with -fPIC Also remove the mksnapshot path override for aarch64, it is not necessary now we run mksnapshot with qemu. This fixes the install step. Bug-AGL: SPEC-2506 Change-Id: Idb90c8c20910ec48ed01f1b02528f14781edc4a3 Signed-off-by: Nick Yamane <nickdiego@igalia.com> Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
Diffstat (limited to 'meta-html5-framework/recipes-wam/chromium/chromium68_git.bb')
-rw-r--r--meta-html5-framework/recipes-wam/chromium/chromium68_git.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
index 70255bf3..28179fd5 100644
--- a/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
+++ b/meta-html5-framework/recipes-wam/chromium/chromium68_git.bb
@@ -30,6 +30,9 @@ SRCREV_v8 = "1e3af71f1ff3735e8a5b639c48dfca63a7b8a647"
SRC_URI_append_armv7a = " file://0001-skia-Build-skcms-with-mfp16-format-ieee-on-GCC-ARM-b.patch"
SRC_URI_append_armv7ve = " file://0001-skia-Build-skcms-with-mfp16-format-ieee-on-GCC-ARM-b.patch"
+# Backport of https://chromium-review.googlesource.com/c/chromium/third_party/ffmpeg/+/1390286
+SRC_URI_append_aarch64 = " file://0001-libavcodec-Remove-dynamic-relocs-from-h264idct_neon..patch"
+
# we don't include SRCPV in PV, so we have to manually include SRCREVs in do_fetch vardeps
do_fetch[vardeps] += "SRCREV_v8"
SRCREV_FORMAT = "main_v8"
@@ -336,7 +339,6 @@ install_chromium_browser() {
MKSNAPSHOT_PATH = ""
MKSNAPSHOT_PATH_arm = "clang_x86_v8_arm/"
-MKSNAPSHOT_PATH_aarch64 = "clang_x64_v8_arm64/"
install_webruntime() {
install -d ${D}${libdir}
r: #0000DD; font-weight: bold } /* Literal.Number.Bin */ .highlight .mf { color: #0000DD; font-weight: bold } /* Literal.Number.Float */ .highlight .mh { color: #0000DD; font-weight: bold } /* Literal.Number.Hex */ .highlight .mi { color: #0000DD; font-weight: bold } /* Literal.Number.Integer */ .highlight .mo { color: #0000DD; font-weight: bold } /* Literal.Number.Oct */ .highlight .sa { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Affix */ .highlight .sb { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Backtick */ .highlight .sc { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Char */ .highlight .dl { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Delimiter */ .highlight .sd { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Doc */ .highlight .s2 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Double */ .highlight .se { color: #0044dd; background-color: #fff0f0 } /* Literal.String.Escape */ .highlight .sh { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Heredoc */ .highlight .si { color: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */ }
/*
 * Copyright (C) 2016 "IoT.bzh"
 * Author Fulup Ar Foll <fulup@iot.bzh>
 *
 * Licensed under the Apache License, Version 2.0 (the "License");
 * you may not use this file except in compliance with the License.
 * You may obtain a copy of the License at
 *
 *   http://www.apache.org/licenses/LICENSE-2.0
 *
 * Unless required by applicable law or agreed to in writing, software
 * distributed under the License is distributed on an "AS IS" BASIS,
 * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 * See the License for the specific language governing permissions and
 * limitations under the License.
 */


#ifndef CONTROLER_BINDING_INCLUDE
#define CONTROLER_BINDING_INCLUDE

#define AFB_BINDING_VERSION 2
#include <afb/afb-binding.h>
#include <json-c/json.h>

#ifndef PUBLIC
  #define PUBLIC
#endif
#define STATIC static


// polctl-binding.c
PUBLIC int CtlBindingInit ();

// ctl-timerevt.c
// ----------------------


PUBLIC int TimerEvtInit (void);
PUBLIC afb_event TimerEvtGet(void);
PUBLIC void ctlapi_event_test (afb_req request);

// ctl-policy
// -----------

typedef enum {
    CTLAPI_NAVIGATION,
    CTLAPI_MULTIMEDIA,
    CTLAPI_EMERGENCY,

    CTL_NONE=-1
} DispatchCtlEnumT;

typedef enum {
  CTL_SCAN_FLAT=0,        
  CTL_SCAN_RECURSIVE=1,
} CtlScanDirModeT;

typedef enum {
    CTL_MODE_NONE=0,
    CTL_MODE_API,
    CTL_MODE_CB,
    CTL_MODE_LUA,        
} CtlRequestModeT;

typedef struct DispatchActionS{
    const char *info;
    const char* label;
    CtlRequestModeT mode;
    const char* api;
    const char* call;
    json_object *argsJ;
    int timeout;
    json_object*  (*actionCB)(struct DispatchActionS *action,json_object *response, void *context);
} DispatchActionT;

PUBLIC int  DispatchInit(void);
PUBLIC void ctlapi_dispatch (DispatchCtlEnumT control, afb_req request);

// ctl-lua.c
PUBLIC int LuaLibInit ();
PUBLIC json_object* ScanForConfig (char* searchPath, CtlScanDirModeT mode, char *pre, char *ext);
PUBLIC void ctlapi_lua_docall (afb_req request);
PUBLIC void ctlapi_lua_dostring (afb_req request);
PUBLIC void ctlapi_lua_doscript (afb_req request);

#endif