aboutsummaryrefslogtreecommitdiffstats
path: root/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2018-12-20 19:47:17 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-01-15 11:15:35 +0000
commit19e71462fc44093c6f9046e60c72adeedfca7858 (patch)
tree98435b324a17bd748204f91be7355ca8cfe59f5f /meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
parent7745e5f40682847aad5d313af65c0f7e70ce3648 (diff)
Integrate Chromium and WAM recipes.
Create a new layer called meta-html5-framework. It contains the following recipes: * chromium68 to build the browser shared library and browser code. * chromium-browser-service for the browser widget. * wam for the web application manager. * wam-tinyproxy is a direct dependency of wam. Defines a new packagegroup, which is added to the agl-demo-platform image in case agl-html5-framework is configured as a feature. Bug-AGL: SPEC-1885 Change-Id: I39f01ab09e198cd139e95ff3c784af563b54329b Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
Diffstat (limited to 'meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb')
-rw-r--r--meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb b/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
new file mode 100644
index 00000000..25a6ed2d
--- /dev/null
+++ b/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Lightweight http(s) proxy daemon"
+HOMEPAGE = "https://tinyproxy.github.io/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/Igalia/${PN}.git;branch=wam-proxy;protocol=https"
+S = "${WORKDIR}/git"
+SRCREV = "ab1b5c5a53960afd91d50b1f11e339f653602de8"
+
+EXTRA_OECONF += " \
+ --enable-filter \
+ --enable-transparent \
+ --enable-reverse \
+ --enable-upstream \
+ --enable-xtinyproxy \
+ "
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/tinyproxy/*"