summaryrefslogtreecommitdiffstats
path: root/meta-html5-framework/recipes-wam/wam
diff options
context:
space:
mode:
authorJacobo Aragunde Pérez <jaragunde@igalia.com>2018-12-20 19:47:17 +0100
committerJacobo Aragunde Pérez <jaragunde@igalia.com>2019-01-15 11:25:41 +0000
commit4a6461a2a52c842efe1b9df668809385ab657b2d (patch)
treefbad7c0fe8731c4228fd264c3a40d50814ab89a2 /meta-html5-framework/recipes-wam/wam
parent9431585b5e02eec40e6644b58909fc6c7095cbe3 (diff)
Integrate Chromium and WAM recipes.
Create a new layer called meta-html5-framework. It contains the following recipes: * chromium68 to build the browser shared library and browser code. * chromium-browser-service for the browser widget. * wam for the web application manager. * wam-tinyproxy is a direct dependency of wam. Defines a new packagegroup, which is added to the agl-demo-platform image in case agl-html5-framework is configured as a feature. Bug-AGL: SPEC-1885 Change-Id: I39f01ab09e198cd139e95ff3c784af563b54329b Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com> (cherry picked from commit 19e71462fc44093c6f9046e60c72adeedfca7858)
Diffstat (limited to 'meta-html5-framework/recipes-wam/wam')
-rw-r--r--meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb20
-rw-r--r--meta-html5-framework/recipes-wam/wam/wam_git.bb46
2 files changed, 66 insertions, 0 deletions
diff --git a/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb b/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
new file mode 100644
index 00000000..25a6ed2d
--- /dev/null
+++ b/meta-html5-framework/recipes-wam/wam/wam-tinyproxy_git.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Lightweight http(s) proxy daemon"
+HOMEPAGE = "https://tinyproxy.github.io/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/Igalia/${PN}.git;branch=wam-proxy;protocol=https"
+S = "${WORKDIR}/git"
+SRCREV = "ab1b5c5a53960afd91d50b1f11e339f653602de8"
+
+EXTRA_OECONF += " \
+ --enable-filter \
+ --enable-transparent \
+ --enable-reverse \
+ --enable-upstream \
+ --enable-xtinyproxy \
+ "
+
+inherit autotools
+
+FILES_${PN} += "${datadir}/tinyproxy/*"
diff --git a/meta-html5-framework/recipes-wam/wam/wam_git.bb b/meta-html5-framework/recipes-wam/wam/wam_git.bb
new file mode 100644
index 00000000..3cf0081c
--- /dev/null
+++ b/meta-html5-framework/recipes-wam/wam/wam_git.bb
@@ -0,0 +1,46 @@
+SUMMARY = "WAM"
+AUTHOR = "Jani Hautakangas <jani.hautakangas@lge.com>"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit qmake5
+
+DEPENDS = "qtbase glib-2.0 jsoncpp chromium68 wayland-ivi-extension libhomescreen libwindowmanager"
+
+PR="r0"
+
+PROVIDES += "virtual/webruntime"
+RPROVIDES_${PN} += "virtual/webruntime"
+
+SRC_URI = "git://github.com/webosose/${PN}.git;branch=@2.chromium68.5.agl.flounder;protocol=https"
+S = "${WORKDIR}/git"
+SRCREV = "fe79cfcf55eff8fc6709ec4845fe6d5a3e9b9e5a"
+
+EXTRA_QMAKEVARS_PRE += "CONFIG_BUILD+=agl_service"
+EXTRA_QMAKEVARS_PRE += "PREFIX=/usr"
+EXTRA_QMAKEVARS_PRE += "PLATFORM=${@'PLATFORM_' + '${DISTRO}'.upper().replace('-', '_')}"
+EXTRA_QMAKEVARS_PRE += "CHROMIUM_SRC_DIR=${STAGING_INCDIR}/chromium68"
+OE_QMAKE_CXXFLAGS += "-Wno-unused-variable"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/wam
+ install -v -m 644 ${S}/files/launch/security_policy.conf ${D}${sysconfdir}/wam/security_policy.conf
+ install -d ${D}${systemd_user_unitdir}
+ install -v -m 644 ${S}/files/launch/WebAppMgr.service ${D}${systemd_user_unitdir}/WebAppMgr.service
+ install -d ${D}${sysconfdir}/default/
+ install -v -m 644 ${S}/files/launch/WebAppMgr.env ${D}${sysconfdir}/default/WebAppMgr.env
+ ln -snf WebAppMgr ${D}${bindir}/web-runtime
+ install -d ${D}${sysconfdir}/systemd/user/default.target.wants
+ ln -sf ${systemd_user_unitdir}/WebAppMgr.service ${D}${sysconfdir}/systemd/user/default.target.wants
+}
+
+pkg_postinst_${PN}_append() {
+ chsmack -a "*" /usr/bin/WebAppMgr
+ chsmack -a "*" /usr/lib/libWebAppMgr.so.1.0.0
+ chsmack -a "*" /usr/lib/libWebAppMgrCore.so.1.0.0
+ chsmack -a "*" /usr/lib/webappmanager/plugins/libwebappmgr-default-plugin.so
+}
+
+RDEPENDS_${PN} += "wam-tinyproxy"
+FILES_${PN} += "${sysconfdir}/init ${sysconfdir}/wam ${libdir}/webappmanager/plugins/*.so ${systemd_user_unitdir}"
+