summaryrefslogtreecommitdiffstats
path: root/meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-10-20 16:17:50 +0900
committertte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-11-02 17:22:04 +0900
commit2c595497e43fadd83ea155f632ba69a31fe923fa (patch)
treefb95e43c8bff0f65da10a43204501181503ab486 /meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch
parentf25d5b743034c65add42639148ff16563a62b044 (diff)
Add software packages for oem needs library
These recipes is support software packages for oem needs. The librarys include: boost, fixesproto, imagemagick, iptables, Xorg-macros zlib, eglibc(glibc), libcurl, libgif, libneon, mongoose fuse, protocol buffers, bsdiff, module-init-tools libcroco, libtiff, librsvg, libpcap, libtar You can add these librarys by feature 'agl-oem-extra-libs' source meta-agl/scripts/aglsetup.sh -m porter agl-demo [agl-appfw-smack] [agl-devel] [agl-netboot] agl-oem-extra-libs v2[jsmoeller]: - change to ImageMagick recipe (generalize configure append and add dependency) - readd libtar with tarball taken from debian as original git is n/a v3[tte_zheng_wenlong] - add libtar and libtar-dev in packagegroup-ivi-common-core-os-commonlibs.bbappend - modify README.md to explain build command. v4[tte_zheng_wenlong] - modify mongoose license from GPLv2 to MIT. - delete [] for agl-oem-extra-libs for README.md Change-Id: I1f9d2f1c023f332d528918c3f730ee0360a1f497 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch')
-rw-r--r--meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch b/meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch
new file mode 100644
index 00000000..99ab509e
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-core/libtar/files/oldgnu_prefix.patch
@@ -0,0 +1,21 @@
+Description: Detect old-style GNU headers correctly
+Author: Steinar H. Gunderson <sesse@debian.org>
+
+--- libtar-1.2.20.orig/lib/decode.c
++++ libtar-1.2.20/lib/decode.c
+@@ -69,7 +69,14 @@ th_get_pathname(TAR *t)
+ return NULL;
+ }
+
+- if (t->th_buf.prefix[0] == '\0')
++ /*
++ * Old GNU headers (also used by newer GNU tar when doing incremental
++ * dumps) use the POSIX prefix field for many other things, such as
++ * mtime and ctime. New-style GNU headers don't, but also don't use the
++ * POSIX prefix field. Thus, only honor the prefix field if the archive
++ * is actually a POSIX archive. This is the same logic as GNU tar uses.
++ */
++ if (strncmp(t->th_buf.magic, TMAGIC, TMAGLEN - 1) != 0 || t->th_buf.prefix[0] == '\0')
+ {
+ sprintf(t->th_pathname, "%.100s", t->th_buf.name);
+ }