summaryrefslogtreecommitdiffstats
path: root/meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-10-20 16:17:50 +0900
committertte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2016-11-02 17:22:04 +0900
commit2c595497e43fadd83ea155f632ba69a31fe923fa (patch)
treefb95e43c8bff0f65da10a43204501181503ab486 /meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb
parentf25d5b743034c65add42639148ff16563a62b044 (diff)
Add software packages for oem needs library
These recipes is support software packages for oem needs. The librarys include: boost, fixesproto, imagemagick, iptables, Xorg-macros zlib, eglibc(glibc), libcurl, libgif, libneon, mongoose fuse, protocol buffers, bsdiff, module-init-tools libcroco, libtiff, librsvg, libpcap, libtar You can add these librarys by feature 'agl-oem-extra-libs' source meta-agl/scripts/aglsetup.sh -m porter agl-demo [agl-appfw-smack] [agl-devel] [agl-netboot] agl-oem-extra-libs v2[jsmoeller]: - change to ImageMagick recipe (generalize configure append and add dependency) - readd libtar with tarball taken from debian as original git is n/a v3[tte_zheng_wenlong] - add libtar and libtar-dev in packagegroup-ivi-common-core-os-commonlibs.bbappend - modify README.md to explain build command. v4[tte_zheng_wenlong] - modify mongoose license from GPLv2 to MIT. - delete [] for agl-oem-extra-libs for README.md Change-Id: I1f9d2f1c023f332d528918c3f730ee0360a1f497 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb')
-rw-r--r--meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb b/meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb
new file mode 100644
index 00000000..904f5c60
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-core/libtar/libtar_1.2.20.bb
@@ -0,0 +1,31 @@
+SUMMARY = "libtar, tar manipulating library"
+DESCRIPTION = "libtar is a library for manipulating POSIX tar files"
+HOMEPAGE = "http://www.feep.net/libtar"
+SECTION = "libs"
+LICENSE = "NCSA"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=61cbac6719ae682ce6cd45b5c11e21af"
+
+# Source and patches taken from debian check there for changes.
+# Check http://repo.or.cz/w/libtar.git/ as upstream.
+# More patches found here: https://github.com/tklauser/libtar
+#
+SRC_URI = "http://httpredir.debian.org/debian/pool/main/libt/libtar/libtar_${PV}.orig.tar.gz"
+SRC_URI += "file://no_static_buffers.patch"
+SRC_URI += "file://no_maxpathlen.patch"
+SRC_URI += "file://CVE-2013-4420.patch"
+SRC_URI += "file://th_get_size-unsigned-int.patch"
+SRC_URI += "file://oldgnu_prefix.patch"
+SRC_URI += "file://testsuite.patch"
+SRC_URI += "file://no_strip.patch"
+
+SRC_URI[md5sum] = "6ced95ab3a4b33fbfe2dfb231d156cdb"
+SRC_URI[sha256sum] = "50f24c857a7ef1cb092e6508758b86d06f1188508f897f3e6b40c573e8879109"
+
+# tarball does not contain PV
+S = "${WORKDIR}/${PN}"
+
+CFLAGS_append = " -DHAVE_STDARG_H"
+
+RDEPENDS_${PN} += "zlib"
+
+inherit autotools