summaryrefslogtreecommitdiffstats
path: root/meta-oem-extra-libs
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2017-06-07 16:00:13 +0900
committertte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2017-06-07 16:05:22 +0900
commita9bbfe1af2ae8ccf79db999e8007b7c6cbc806a1 (patch)
treef63c3e0b6b0f5971eaaa050aba985a520d1ea898 /meta-oem-extra-libs
parentcadc1155dbd979728dcf6a59110f1087f57ccedf (diff)
Add oem needs libs, libdatrie and libthai.
Libthai is a set of Thai language support routines aimed to ease developers’ tasks to incorporate Thai language support in their applications. Libdatrie's full name is double-array trie. Trie is a kind of digital search tree, and libdatrie is used by libthai. Change-Id: I02a97bb6b1286070c443fecc0dce0e17c7f00016 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>
Diffstat (limited to 'meta-oem-extra-libs')
-rw-r--r--meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend2
-rwxr-xr-xmeta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb28
-rwxr-xr-xmeta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb13
3 files changed, 43 insertions, 0 deletions
diff --git a/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend b/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
index 2b7fe6a0..fbd7b976 100644
--- a/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
+++ b/meta-oem-extra-libs/recipes-core/packagegroups/packagegroup-ivi-common-core-os-commonlibs.bbappend
@@ -47,4 +47,6 @@ RDEPENDS_${PN} += "\
libogg \
thrift \
ppp \
+ libdatrie \
+ libthai \
"
diff --git a/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb b/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb
new file mode 100755
index 00000000..f317eb21
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-support/libdatrie/libdatrie_0.2.9.bb
@@ -0,0 +1,28 @@
+#
+# No base recipe
+#
+
+DESCRIPTION = "datrie is an implementation of double-array structure \
+for representing trie, as proposed by Junichi Aoe."
+HOMEPAGE = "http://linux.thai.net/projects/libthai"
+
+PR = "r0"
+
+inherit autotools pkgconfig
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+SRC_URI = "http://linux.thai.net/pub/thailinux/software/libthai/${PN}-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "687624f374e748de81b01399736bb735"
+SRC_URI[sha256sum] = "d980713e7ad8e19cf3b54ee0173782b94332af8e7e4e936dde01d2cd72e1da1d"
+
+
+# Add more packages
+PACKAGES =+ "${PN}1-bin"
+
+FILES_${PN}1-bin += "${bindir}/*"
+
+#BBCLASSEXTEND += "native"
+
diff --git a/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb b/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb
new file mode 100755
index 00000000..ce8dc17c
--- /dev/null
+++ b/meta-oem-extra-libs/recipes-support/libthai/libthai_0.1.20.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Thai language support routines"
+LICENSE = "LGPL"
+DEPENDS = "libdatrie"
+
+SRC_URI = "http://linux.thai.net/pub/thailinux/software/libthai/${PN}-${PV}.tar.xz"
+
+inherit autotools pkgconfig
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+SRC_URI[md5sum] = "2b58148d73361316121d5384efeda9e6"
+SRC_URI[sha256sum] = "5a107f5a4dc5433ec6deb744435a4d8dc89daec0a189b9c76a90648fda0ef7ed"