summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-12-19 16:13:15 -0500
committerScott Murray <scott.murray@konsulko.com>2020-12-21 09:41:02 -0500
commitaf25a3b5a46c74124f1fb99e7157cc6aea879a5c (patch)
tree5a6ba2e217d11d6145f6a00226715e520a441d8d /meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
parent4e5b9be85750852559f22b0b3493e6074b8f4fac (diff)
meta-agl-basesystem: add libxml-xpath-perl
Add libxml-xpath-perl recipe and recipes for its required dependencies libscalar-list-utils-perl and libpath-tiny-perl. This should enable using the xpath utility in the basesystem build by DEPENDing on libxml-xpath-perl-native. Note that the libscalar-list-utils-perl recipe has been adapted from the one present in meta-cpan (https://github.com/meta-cpan/meta-cpan) as of commit 2f6ecfa. This was viewed as preferable to pulling in meta-cpan as an AGL dependency. Additionally, the recipe has been updated to enable ptest support, and all tests have been confirmed to pass. The same is true of the libxml-xpath-perl and libpath-tiny-perl ptests. Bug-AGL: SPEC-3670 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Icd25cbb4498636c5a6a384818535e3c3372b5b29
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
new file mode 100644
index 00000000..3f7af7ad
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Path::Tiny - File path utility"
+DESCRIPTION = "This module provides a small, fast utility for working with \
+file paths. It is friendlier to use than File::Spec and provides easy access \
+to functions from several other core file handling modules"
+HOMEPAGE = "https://github.com/dagolden/Path-Tiny"
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/Path-Tiny-${PV}.tar.gz"
+SRC_URI[sha256sum] = "cd0f88f37a58fc3667ec065767fe01e73ee6efa18a112bfd3508cf6579ca00e1"
+
+S = "${WORKDIR}/Path-Tiny-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS_${PN} += " \
+ perl-module-file-spec \
+ perl-module-file-temp \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"