summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
commit37d3b1b316470fdcfebc59d5522bfbfefc025ff6 (patch)
treecf70d6c9e3832d8734de4f66f2d0fe52b104c9fd /meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools
parentab5f7f52dbdbea04d1f79310cbf08922a5371345 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0bbae97331abee1367b368ce54ab39e3162a12ec
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libscalar-list-utils-perl_1.55.bb2
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb6
3 files changed, 5 insertions, 5 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
index 3f7af7ad..b28c0178 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libpath-tiny-perl_0.114.bb
@@ -15,7 +15,7 @@ S = "${WORKDIR}/Path-Tiny-${PV}"
inherit cpan ptest-perl
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
perl-module-file-spec \
perl-module-file-temp \
perl-module-test-more \
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libscalar-list-utils-perl_1.55.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libscalar-list-utils-perl_1.55.bb
index d81f18ff..72780a67 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libscalar-list-utils-perl_1.55.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libscalar-list-utils-perl_1.55.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/Scalar-List-Utils-${PV}"
inherit cpan ptest-perl
-do_install_prepend() {
+do_install:prepend() {
# requires "-T" (taint) command line option
rm -rf ${B}/t/tainted.t
}
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
index 3f130550..3049ceda 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-devtools/perl/libxml-xpath-perl_1.44.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/XML-XPath-${PV}"
inherit cpan ptest-perl
-do_install_append_class-native() {
+do_install:append:class-native() {
# Fix xpath script shebang to work inside native environment
sed -i 's|#!.*/perl|#!/usr/bin/env perl|' ${D}${bindir}/xpath
}
@@ -24,7 +24,7 @@ do_install_ptest() {
install -m 0644 ${S}/examples/test.xml ${D}${PTEST_PATH}/examples/
}
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
perl-module-carp \
perl-module-data-dumper \
perl-module-file-spec \
@@ -38,7 +38,7 @@ RDEPENDS_${PN} += " \
libscalar-list-utils-perl \
"
-RDEPENDS_${PN}-ptest += " \
+RDEPENDS:${PN}-ptest += " \
libpath-tiny-perl \
"