summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb
diff options
context:
space:
mode:
authorRiku Nomoto <riku.nomoto@woven-planet.global>2020-11-26 23:12:55 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-14 16:29:30 +0000
commit1cd6f8c6a86baae99a9cc33c067ebcbe4647faeb (patch)
tree1bb0bd868d990c8f7e96b633cba27ed389bc01b1 /meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb
parentfdf2a2eb9ac9e6d71643ec12cde326f4ddd30813 (diff)
oem-pr-bs: add backup mng and mem access libs
This is the sixth commit of agl-basesystem. Service backup manager and non-volatile memory access library v12 (jsmoeller): fix build of multiple packages v18 (nomoto): change mail address and author v23 (nomoto): make hal recipes inherit bshalmake Bug-AGL: SPEC-3670 Signed-off-by: Riku Nomoto <riku.nomoto@woven-planet.global> Change-Id: I64497d80424c136da75e13132bc192f70cba6fac
Diffstat (limited to 'meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb
new file mode 100644
index 00000000..06dadcd8
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ns-backupmanager/ns-backupmanager_1.0.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "ns-backupmanager for AGL software"
+DESCRIPTION = "ns-backupmanager to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ libxml2-native \
+ ns-frameworkunified \
+ libnv-hal \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/native/backup_manager"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += " \
+ ${libdir}/* \
+"
+
+RDEPENDS_${PN} += " \
+ ns-frameworkunified \
+ libnv-hal \
+"