summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-11-02 03:29:04 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-03 19:03:36 +0000
commit64889c4c525c4c66fb74dd703a1cbc0375bc405d (patch)
treed95eaebe015ffb1695ec39f5524832cd1a7f761a /meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
parent832fb66cc1dad280410e828547e97315741f085d (diff)
Update voice agent related recipes
Change the SRCURI to use gerrit repos. Update agl-service-voicegent recipe to correctly package all the required content. Add recipe for another en-us vosk model. Add service files for RASA and Voice Agent server. Bug-AGL: SPEC-4906 Change-Id: Ic9f77386ff5c545c2a80433dd538c94bd8763e9e Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
new file mode 100644
index 00000000..edcb9fe4
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Voice Assistant"
+DESCRIPTION = "Offline voice assistant app designed for Automotive Grade Linux (AGL)."
+HOMEPAGE = "https://github.com/malik727/agl-flutter-voiceassistant"
+BUGTRACKER = "https://github.com/malik727/agl-flutter-voiceassistant/issues"
+SECTION = "graphics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
+
+SRC_URI = "\
+ git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
+ "
+
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_voiceassistant"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_voiceassistant"
+AGL_APP_NAME = "Voice Assistant" \ No newline at end of file