summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-app
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-assistant/voiceagent-app
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-app')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service9
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb15
2 files changed, 20 insertions, 4 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
new file mode 100644
index 00000000..101326b3
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/files/agl-app-flutter@flutter_voiceassistant.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=flutter_voiceassistant
+
+[Service]
+Type=simple
+User=agl-driver
+EnvironmentFile=/etc/default/flutter
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStart=/usr/bin/flutter-auto --b=/flutter/flutter_voiceassistant/${FLUTTER_VERSION}/${FLUTTER_RUNTIME} --xdg-shell-app-id=flutter_voiceassistant
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
index edcb9fe4..67263790 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-app/flutter-voiceassistant_git.bb
@@ -8,12 +8,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
SRC_URI = "\
git://gerrit.automotivelinux.org/gerrit/apps/flutter-speechrecognition-demo;protocol=https;branch=${AGL_BRANCH} \
- "
-
+ file://agl-app-flutter@flutter_voiceassistant.service \
+"
+
SRCREV = "${AUTOREV}"
S = "${WORKDIR}/git"
-inherit agl-app flutter-app
+inherit agl-app flutter-app
# flutter-app
#############
@@ -25,4 +26,10 @@ FLUTTER_BUILD_ARGS = "bundle -v"
#########
AGL_APP_TEMPLATE = "agl-app-flutter"
AGL_APP_ID = "flutter_voiceassistant"
-AGL_APP_NAME = "Voice Assistant" \ No newline at end of file
+AGL_APP_NAME = "Voice Assistant"
+
+do_install:append() {
+ install -D -m 0644 ${WORKDIR}/agl-app-flutter@flutter_voiceassistant.service ${D}${systemd_system_unitdir}/agl-app-flutter@flutter_voiceassistant.service
+}
+
+FILES:${PN} += "${datadir} "