summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-09-30 23:39:02 +0200
committerAnuj Solanki <anuj603362@gmail.com>2024-10-06 16:25:15 +0200
commit8949e1b030da7067da206a580c5124ca85ec9fbc (patch)
tree9eec1daea3ded33862a310aa66e83864acf8abc2 /meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
parent1feb55631bea43bf7745921e247706303db4d6fc (diff)
Remove OpenAI's Whisper AI and its dependencies
- Remove OpenAI's Whisper AI recipes and all its dependencies. - Add recipes for whisper-cpp, whisper-cpp-base and whisper-cpp-tiny model. - Add recipe for python-mpd. - Add voice-agent-config to /etc/default and update config path in agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: Iaebd9c46930144b41659710202e9b737dbe9f60b Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb')
-rw-r--r--meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb18
1 files changed, 12 insertions, 6 deletions
diff --git a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
index e1f1cc50..aedab006 100644
--- a/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
+++ b/meta-offline-voice-agent/recipes-assistant/voiceagent-service/agl-service-voiceagent_git.bb
@@ -1,11 +1,12 @@
SUMMARY = "A gRPC-based voice agent service designed for Automotive Grade Linux (AGL)."
-HOMEPAGE = "https://github.com/malik727/agl-service-voiceagent"
+.HOMEPAGE = "https://github.com/malik727/agl-service-voiceagent"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=4202492ed9afcab3aaecc4a9ec32adb2"
SRC_URI = " \
- file://agl-service-voiceagent.service \
git://gerrit.automotivelinux.org/gerrit/apps/agl-service-voiceagent;protocol=https;branch=${AGL_BRANCH} \
+ file://agl-service-voiceagent.service \
+ file://voice-agent-config.ini \
"
SRCREV = "${AUTOREV}"
@@ -15,7 +16,7 @@ S = "${WORKDIR}/git"
VOSK_STT_MODEL_NAME ?= "vosk-model-small-en-us-0.15"
# Wake Word Detection Model Name
VOSK_WWD_MODEL_NAME ?= "vosk-model-small-en-us-0.15"
-WAKE_WORD ?= "hello auto"
+WAKE_WORD ?= "hey automotive"
DEPENDS += " \
python3 \
@@ -53,8 +54,12 @@ do_install:append() {
# Initialize our service definition
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/agl-service-voiceagent.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/agl-service-voiceagent.service ${D}${systemd_system_unitdir}/agl-service-voiceagent.service
fi
+
+ # Copy config file to etc/default
+ install -d ${D}/etc/default/
+ cp -R ${WORKDIR}/voice-agent-config.ini ${D}/etc/default/
}
RDEPENDS:${PN} += " \
@@ -65,7 +70,8 @@ RDEPENDS:${PN} += " \
kuksa-client \
python3-snips-inference-agl \
vosk \
- whisper \
+ whisper-cpp \
+ python3-python-mpd2 \
"
-FILES:${PN} += "/usr/share/nlu/"
+FILES:${PN} += "/usr/share/nlu/ /etc/default/"