summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-nlu
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-nlu
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-nlu')
-rw-r--r--meta-offline-voice-agent/recipes-nlu/nlu-model/snips-model-agl_0.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-nlu/nlu-model/snips-model-agl_0.2.0.bb b/meta-offline-voice-agent/recipes-nlu/nlu-model/snips-model-agl_0.2.0.bb
new file mode 100644
index 00000000..6d191baf
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-nlu/nlu-model/snips-model-agl_0.2.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Dataset and a pre-trained model for the Automotive Grade Linux's Snips NLU intent engine."
+HOMEPAGE = "https://github.com/malik727/snips-model-agl"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ecab3ce0771d366e0f8e4ca058eb48e7"
+
+SRC_URI = " \
+ git://github.com/malik727/snips-model-agl.git;protocol=https;branch=main \
+"
+
+PV = "1.0.0+git${SRCPV}"
+SRCREV = "${AUTOREV}"
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}/usr/share/nlu/snips
+ cp -R ${WORKDIR}/git/* ${D}/usr/share/nlu/snips/
+}
+
+FILES:${PN} += " /usr/share/nlu/snips"