summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/files
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-rasa/files
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/files')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch
new file mode 100644
index 00000000..ed277bb2
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch
@@ -0,0 +1,36 @@
+From 39ab95117545461b06836d3033002f040f34624d Mon Sep 17 00:00:00 2001
+From: Anuj Solanki <anuj603362@gmail.com>
+Date: Fri, 14 Jun 2024 19:36:03 +0200
+Subject: [PATCH] Structlog setup.py fix
+
+This patch updates setup.py for structlog to correctly read the
+long_description from README.md and removes the dynamic field.
+
+Upstream-Status: Inaproppriate.
+Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
+---
+ setup.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 4bc2b79..6d2a048 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,10 +1,16 @@
+ from setuptools import setup, find_packages
+
++def read_readme():
++ with open("README.md", "r", encoding="utf-8") as f:
++ return f.read()
++
++
+ setup(
+ name="structlog",
+ version="23.1.0",
+- dynamic=["readme", "version"],
+ description="Structured Logging for Python",
++ long_description=read_readme(),
++ long_description_content_type="text/markdown",
+ author="Hynek Schlawack",
+ author_email="hs@ox.cx",
+ url="https://github.com/hynek/structlog",