summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb
new file mode 100644
index 00000000..c0b42eb5
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-apscheduler_3.9.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Task scheduling library for Python"
+HOMEPAGE = "https://github.com/agronholm/apscheduler"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f0e423eea5c91e7aa21bdb70184b3e53"
+
+PYPI_PACKAGE = "APScheduler"
+
+SRC_URI[md5sum] = "bdf3d90556514b99e2104dbf9a206546"
+SRC_URI[sha256sum] = "65e6574b6395498d371d045f2a8a7e4f7d50c6ad21ef7313d15b1c7cf20df1e3"
+
+DEPENDS += " \
+ python3-attrs \
+ python3-anyio \
+ python3-tzlocal \
+ python3-typing-extensions \
+ "
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += " \
+ python3-attrs \
+ python3-anyio \
+ python3-tzlocal \
+ python3-typing-extensions \
+ "