summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb
new file mode 100644
index 00000000..a63cb971
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-dask_2022.10.2.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Parallel computing with task scheduling"
+HOMEPAGE = "https://github.com/dask/dask"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f5eb2002f2deb4e003875dd453131e73"
+
+PYPI_PACKAGE = "dask"
+
+SRC_URI[md5sum] = "ec92d1ff05c60e0df0cf96753bc818a9"
+SRC_URI[sha256sum] = "42cb43f601709575fa46ce09e74bea83fdd464187024f56954e09d9b428ceaab"
+
+DEPENDS += " \
+ python3-click \
+ python3-pyyaml \
+ python3-packaging \
+ python3-cloudpickle \
+ python3-fsspec \
+ python3-partd \
+ python3-toolz \
+ "
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-click \
+ python3-pyyaml \
+ python3-packaging \
+ python3-cloudpickle \
+ python3-fsspec \
+ python3-partd \
+ python3-toolz \
+ "