summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb
new file mode 100644
index 00000000..196db185
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-requests-toolbelt_1.0.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A toolbelt of useful classes and functions to be used with python-requests"
+HOMEPAGE = "https://github.com/requests/toolbelt"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6f14302a4b4099009ab38b4dde5f1075"
+
+PYPI_PACKAGE = "requests-toolbelt"
+
+SRC_URI[md5sum] = "6a8348cfc9991b44e499345db1c6f925"
+SRC_URI[sha256sum] = "7681a0a3d047012b5bdc0ee37d7f8f07ebe76ab08caeccfc3921ce23c88d5bc6"
+
+DEPENDS += "python3-requests"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-requests"