summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
committerMalik Talha <talhamalik727x@gmail.com>2023-10-06 23:42:08 +0500
commit7b4a029168133bbf58c5dfe97e618badfe77b361 (patch)
treeb8f63ff4baec31ba5ca7feb815869b30ccc653ba /meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb
parent713efdf66dca8e60c3db1e720a9bb2bd074c40f3 (diff)
Add dependencies for RASA framework
This adds the libraries for the RASA machine learning framework. Bug-AGL: SPEC-4856 Change-Id: I477b09cae8ff51e284b51238cb5940464ea57a51 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb
new file mode 100644
index 00000000..2801eed1
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml_0.17.21.bb
@@ -0,0 +1,15 @@
+SUMMARY = "ruamel.yaml is a YAML 1.2 parser/emitter for Python"
+HOMEPAGE = "https://sourceforge.net/projects/ruamel-yaml/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=034154b7344d15438bc5ed5ee9cc075f"
+
+PYPI_PACKAGE = "ruamel.yaml"
+
+SRC_URI[md5sum] = "206bda0f33ab2c2f63777636200748b7"
+SRC_URI[sha256sum] = "8b7ce697a2f212752a35c1ac414471dc16c424c9573be4926b56ff3f5d23b7af"
+
+DEPENDS += "python3-ruamel.yaml.clib python3-setuptools-native"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-ruamel.yaml.clib"