summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
new file mode 100644
index 00000000..89ed8bc1
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Ultra fast asyncio event loop."
+HOMEPAGE = "https://github.com/MagicStack/uvloop"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE-APACHE;md5=bb92739ddad0a2811957bd98bdb90474"
+
+PYPI_PACKAGE = "uvloop"
+
+SRC_URI[md5sum] = "a7679334af9a39dc89f9298088d8d235"
+SRC_URI[sha256sum] = "d5d1135beffe9cd95d0350f19e2716bc38be47d5df296d7cc46e3b7557c0d1ff"
+
+DEPENDS += "python3-cython-native"
+
+inherit pypi setuptools3
+
+do_compile:prepend() {
+ export LIBUV_CONFIGURE_HOST=${HOST_SYS}
+}
+
+do_install:prepend() {
+ export LIBUV_CONFIGURE_HOST=${HOST_SYS}
+}