summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-rasa
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-rasa
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-rasa')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch36
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.7.bb11
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.8.bb11
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-structlog_23.1.0.bb3
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb (renamed from meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.17.0.bb)4
5 files changed, 51 insertions, 14 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch
new file mode 100644
index 00000000..ed277bb2
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/files/0001-Structlog-setup.py-fix.patch
@@ -0,0 +1,36 @@
+From 39ab95117545461b06836d3033002f040f34624d Mon Sep 17 00:00:00 2001
+From: Anuj Solanki <anuj603362@gmail.com>
+Date: Fri, 14 Jun 2024 19:36:03 +0200
+Subject: [PATCH] Structlog setup.py fix
+
+This patch updates setup.py for structlog to correctly read the
+long_description from README.md and removes the dynamic field.
+
+Upstream-Status: Inaproppriate.
+Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
+---
+ setup.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 4bc2b79..6d2a048 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,10 +1,16 @@
+ from setuptools import setup, find_packages
+
++def read_readme():
++ with open("README.md", "r", encoding="utf-8") as f:
++ return f.read()
++
++
+ setup(
+ name="structlog",
+ version="23.1.0",
+- dynamic=["readme", "version"],
+ description="Structured Logging for Python",
++ long_description=read_readme(),
++ long_description_content_type="text/markdown",
+ author="Hynek Schlawack",
+ author_email="hs@ox.cx",
+ url="https://github.com/hynek/structlog",
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.7.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.7.bb
deleted file mode 100644
index 33904881..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.7.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-SUMMARY = "C version of reader, parser and emitter for ruamel.yaml"
-HOMEPAGE = "https://sourceforge.net/projects/ruamel-yaml-clib/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=835b7de93e6217192ffce476ecb74e86"
-
-PYPI_PACKAGE = "ruamel.yaml.clib"
-
-SRC_URI[md5sum] = "4b7bc49c0022baf161203dc1ea4806f9"
-SRC_URI[sha256sum] = "1f08fd5a2bea9c4180db71678e850b995d2a5f4537be0e94557668cf0f5f9497"
-
-inherit pypi setuptools3
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.8.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.8.bb
new file mode 100644
index 00000000..76f12758
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-ruamel.yaml.clib_0.2.8.bb
@@ -0,0 +1,11 @@
+SUMMARY = "C version of reader, parser and emitter for ruamel.yaml"
+HOMEPAGE = "https://sourceforge.net/projects/ruamel-yaml-clib/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1debc1593104ded7e88b0ac5659af552"
+
+PYPI_PACKAGE = "ruamel.yaml.clib"
+
+SRC_URI[md5sum] = "b72e549363fa1b9c4f9123e98f2b46cc"
+SRC_URI[sha256sum] = "beb2e0404003de9a4cab9753a8805a8fe9320ee6673136ed7f04255fe60bb512"
+
+inherit pypi setuptools3
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-structlog_23.1.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-structlog_23.1.0.bb
index c93cae88..9900901c 100644
--- a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-structlog_23.1.0.bb
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-structlog_23.1.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=0473cdcf9c6ed3f81c08d886870daea5"
PYPI_PACKAGE = "structlog"
-SRC_URI += "file://0001-structlog-add-setup-file.patch"
+SRC_URI += " file://0001-structlog-add-setup-file.patch"
+SRC_URI += " file://0001-Structlog-setup.py-fix.patch"
SRC_URI[md5sum] = "bd2218c8799e44a90689bbdeadcab4f3"
SRC_URI[sha256sum] = "270d681dd7d163c11ba500bc914b2472d2b50a8ef00faa999ded5ff83a2f906b"
diff --git a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.17.0.bb b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
index 2c6d2880..89ed8bc1 100644
--- a/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.17.0.bb
+++ b/meta-offline-voice-agent/recipes-python/python3-rasa/python3-uvloop_0.18.0.bb
@@ -5,8 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE-APACHE;md5=bb92739ddad0a2811957bd98bdb90474"
PYPI_PACKAGE = "uvloop"
-SRC_URI[md5sum] = "bc5e841a1c3f6e8935eeaf9d82b5ee29"
-SRC_URI[sha256sum] = "0ddf6baf9cf11a1a22c71487f39f15b2cf78eb5bde7e5b45fbb99e8a9d91b9e1"
+SRC_URI[md5sum] = "a7679334af9a39dc89f9298088d8d235"
+SRC_URI[sha256sum] = "d5d1135beffe9cd95d0350f19e2716bc38be47d5df296d7cc46e3b7557c0d1ff"
DEPENDS += "python3-cython-native"