summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch b/meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch
deleted file mode 100644
index 8a874af4..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-scipy/files/0001-Allow-passing-flags-via-FARCH-for-mach.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 973767f29391eca1c76292556de03cdd7520c07d Mon Sep 17 00:00:00 2001
-From: Erik Boto <erik.boto@gmail.com>
-Date: Tue, 3 Nov 2020 09:08:56 -0700
-Subject: [PATCH] Allow passing flags via FARCH for mach
-
-Enable passing options via FARCH, so that the flags for setting the
-correct floating point ABI is propagated properly to the fortran
-compiler.
-
-This fixes an issue where the mach lib would otherwise be built as
-soft-float, even though the target arch is hard-float.
----
- scipy/integrate/setup.py | 3 +--
- scipy/special/setup.py | 3 +--
- 2 files changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/scipy/integrate/setup.py b/scipy/integrate/setup.py
-index 11ce3d1..8e4a3dc 100755
---- a/scipy/integrate/setup.py
-+++ b/scipy/integrate/setup.py
-@@ -34,8 +34,7 @@ def configuration(parent_package='',top_path=None):
- quadpack_test_src = [join('tests','_test_multivariate.c')]
- odeint_banded_test_src = [join('tests', 'banded5x5.f')]
-
-- config.add_library('mach', sources=mach_src, config_fc={'noopt': (__file__, 1)},
-- _pre_build_hook=pre_build_hook)
-+ config.add_library('mach', sources=mach_src, _pre_build_hook=pre_build_hook)
- config.add_library('quadpack', sources=quadpack_src, _pre_build_hook=pre_build_hook)
- config.add_library('lsoda', sources=lsoda_src, _pre_build_hook=pre_build_hook)
- config.add_library('vode', sources=vode_src, _pre_build_hook=pre_build_hook)
-diff --git a/scipy/special/setup.py b/scipy/special/setup.py
-index 81eb09f..260cfb3 100755
---- a/scipy/special/setup.py
-+++ b/scipy/special/setup.py
-@@ -46,8 +46,7 @@ def configuration(parent_package='',top_path=None):
- amos_src = [join('amos','*.f')]
- cdf_src = [join('cdflib','*.f')]
- specfun_src = [join('specfun','*.f')]
-- config.add_library('sc_mach',sources=mach_src,
-- config_fc={'noopt':(__file__,1)})
-+ config.add_library('sc_mach',sources=mach_src)
- config.add_library('sc_amos',sources=amos_src)
- config.add_library('sc_cdf',sources=cdf_src)
- config.add_library('sc_specfun',sources=specfun_src)