summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb b/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
deleted file mode 100644
index 1f562ebf..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-scipy/python3-scipy_1.8.1.bb
+++ /dev/null
@@ -1,54 +0,0 @@
-SUMMARY = "SciPy: Scientific Library for Python"
-HOMEPAGE = "https://www.scipy.org"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=27ca2e35416b6316570bf126e08b7062"
-
-SRC_URI += " \
- file://0001-Allow-passing-flags-via-FARCH-for-mach.patch \
- file://static-lib.patch \
-"
-SRC_URI[md5sum] = "df5ce79288fc457238aeef18e8f70dfc"
-SRC_URI[sha256sum] = "9e3fb1b0e896f14a85aa9a28d5f755daaeeb54c897b746df7a55ccb02b340f33"
-
-DEPENDS += " \
- ${PYTHON_PN}-numpy \
- ${PYTHON_PN}-numpy-native \
- ${PYTHON_PN}-pybind11-native \
- ${PYTHON_PN}-pythran-native \
- ${PYTHON_PN}-gast-native \
- ${PYTHON_PN}-beniget-native \
- ${PYTHON_PN}-ply-native \
- lapack \
- openblas \
-"
-
-inherit pypi setuptools3
-
-RDEPENDS:${PN} += " \
- ${PYTHON_PN}-numpy \
- lapack \
- openblas \
-"
-
-CLEANBROKEN = "1"
-
-export LAPACK = "${STAGING_LIBDIR}"
-export BLAS = "${STAGING_LIBDIR}"
-
-export F90 = "${TARGET_PREFIX}gfortran"
-export F77 = "${TARGET_PREFIX}gfortran"
-export FARCH = "${TUNE_CCARGS}"
-
-export NUMPY_INCLUDE_PATH = "${STAGING_DIR_TARGET}/usr/lib/python${PYTHON_BASEVERSION}/site-packages/numpy/core/include"
-
-# Numpy expects the LDSHARED env variable to point to a single
-# executable, but OE sets it to include some flags as well. So we split
-# the existing LDSHARED variable into the base executable and flags, and
-# prepend the flags into LDFLAGS
-LDFLAGS:prepend := "${@" ".join(d.getVar('LDSHARED', True).split()[1:])} "
-export LDSHARED := "${@d.getVar('LDSHARED', True).split()[0]}"
-
-# Tell Numpy to look in target sysroot site-packages directory for libraries
-LDFLAGS:append = " -L${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/numpy/core/lib"
-
-INSANE_SKIP:${PN} = "already-stripped"