summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb
new file mode 100644
index 00000000..d1ca38fe
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-num2words_0.5.12.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Modules to convert numbers to words"
+HOMEPAGE = "https://github.com/savoirfairelinux/num2words"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f1b68565299e4b2403b8b3a87d0bcacf"
+
+PYPI_PACKAGE = "num2words"
+
+SRC_URI[md5sum] = "6ef51562822308f7e20f8059d2a81686"
+SRC_URI[sha256sum] = "7e7c0b0f080405aa3a1dd9d32b1ca90b3bf03bab17b8e54db05e1b78301a0988"
+
+DEPENDS += "python3-docopt python3-setuptools-native"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-docopt"
+BBCLASSEXTEND = "native" \ No newline at end of file