summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb
new file mode 100644
index 00000000..6cfc34df
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-pyaml_19.12.0.bb
@@ -0,0 +1,16 @@
+SUMMARY = "PyYAML-based module to produce a bit more pretty and readable YAML-serialized data"
+HOMEPAGE = "https://github.com/mk-fg/pretty-yaml"
+LICENSE = "WTFPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cb6845a9953333608b280507d7803cb3"
+
+PYPI_PACKAGE = "pyaml"
+
+SRC_URI[md5sum] = "a41620eeb64f4b460e6d23b98156780e"
+SRC_URI[sha256sum] = "b3f636b467864319d7ded1558f86bb305b8612a274f5d443a62dc5eceb1b7176"
+
+DEPENDS += "python3-pyyaml python3-setuptools-native"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "python3-pyyaml"
+BBCLASSEXTEND = "native" \ No newline at end of file