summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
new file mode 100644
index 00000000..d7ced8eb
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-parsers_0.4.3.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Python wrapper of the snips-nlu-parsers Rust crate"
+HOMEPAGE = "https://github.com/snipsco/snips-nlu-parsers"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = " \
+ file://../LICENSE-APACHE;md5=1836efb2eb779966696f473ee8540542 \
+ file://../LICENSE-MIT;md5=b377b220f43d747efdec40d69fcaa69d \
+ "
+
+SRC_URI += " \
+ git://github.com/snipsco/snips-nlu-parsers;protocol=https;branch=master \
+ "
+
+PV = "0.4.3+git${SRCPV}"
+SRCREV = "8cfdae50437732fcf906af90626c8db196729d30"
+S = "${WORKDIR}/git/python"
+
+DEPENDS += "python3-future python3-setuptools-rust-native"
+
+require ${BPN}-crates.inc
+
+inherit cargo python_setuptools3_rust
+
+do_compile[network] = "1"
+
+RDEPENDS:${PN} += "python3-future"