summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb
new file mode 100644
index 00000000..491e4633
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-snips-inference/python3-snips-nlu-utils_0.9.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python wrapper of rust library for NLU utils with wrappers in other languages"
+HOMEPAGE = "https://github.com/snipsco/snips-nlu-utils"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=fdebc354a9200f9dc847e624d4584ea9"
+
+SRC_URI += " \
+ git://github.com/malik727/snips-nlu-utils.git;protocol=https;branch=master \
+ "
+
+PV = "0.9.1+git${SRCPV}"
+S = "${WORKDIR}/git/python"
+SRCREV = "b632934413bf84a733cd745db33a0c83640eada8"
+
+DEPENDS += "python3-setuptools-rust-native"
+
+require ${BPN}-crates.inc
+
+inherit cargo python_setuptools3_rust
+
+do_compile[network] = "1" \ No newline at end of file