summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-srt
diff options
context:
space:
mode:
authoramanarora_09 <aman.arora9848@gmail.com>2022-07-22 15:58:23 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-28 13:58:18 +0000
commiteda84d25d819824d641cf89af1e4d61a5e946744 (patch)
tree38f4b7c34a5b91257518bcbcdc6b96d24f0641b2 /meta-offline-voice-agent/recipes-python/python3-srt
parentf206eab5753bd9ee2d5b1126c6ec5a18e75cac89 (diff)
meta-offline-voice-agent: Enable layer for offline voice recognition
- This enables offline voice recognition in AGL - Can successfully run vosk API and vosk websocket server Changes: - Create a new layer: meta-offline-voice-recognition - Create recipes for the the Vosk library, API, websocket server and model - Create feature template for the layer (agl-offline-voice-agent) - Add all required packages to IMAGE_INSTALL - ptest enable recipe python3-vosk-api - Few fixes Bug-AGL: SPEC-4497 Change-Id: Icb290ceee22e2c3a51cbd67f7431701795f1201b Signed-off-by: amanarora_09 <aman.arora9848@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-srt')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-srt/python3-srt_3.5.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-srt/python3-srt_3.5.2.bb b/meta-offline-voice-agent/recipes-python/python3-srt/python3-srt_3.5.2.bb
new file mode 100644
index 00000000..258fc521
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-srt/python3-srt_3.5.2.bb
@@ -0,0 +1,16 @@
+SUMMARY = "A tiny library for parsing, modifying, and composing SRT files."
+HOMEPAGE = "https://github.com/cdown/srt"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6658a1272b4469f7249985d28b8697bb"
+
+SRC_URI = "https://files.pythonhosted.org/packages/18/a3/e1466f7c86a9e5d3e462ed6eb3a548917e93cc1ee212cd927f8f4e887ae9/srt-${PV}.tar.gz"
+SRC_URI[md5sum] = "3b68be7c46ec6152123fd801f519a63d"
+SRC_URI[sha256sum] = "7aa4ad5ce4126d3f53b3e7bc4edaa86653d0378bf1c0b1ab8c59f5ab41384450"
+
+S = "${WORKDIR}/srt-${PV}"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += "python3-core python3-datetime python3-logging"
+
+BBCLASSEXTEND = "native nativesdk" \ No newline at end of file