summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
diff options
context:
space:
mode:
authorMalik Talha <talhamalik727x@gmail.com>2023-09-28 15:50:31 +0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-10-05 13:25:58 +0000
commit35e7b9d2774e8d104d0693e0a0758363c2afb16d (patch)
tree926eb79fc153cf68ed6b7a54cf68f6894ef50f07 /meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
parent39319e3a3bdfcc6c6da47035bf04b4255aec09e5 (diff)
Add dependencies for intent engine snips
This adds the libraries for the snips intent engine. Bug-AGL: SPEC-4856 Change-Id: I0acec6fdd1d0809ee2a0a52ee2c95cd86671d760 Signed-off-by: Malik Talha <talhamalik727x@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb b/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
new file mode 100644
index 00000000..9fed3639
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Python helpers to limit the number of threads used \
+ in native libraries that handle their own internal threadpool"
+HOMEPAGE = "https://github.com/joblib/threadpoolctl"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8f2439cfddfbeebdb5cac3ae4ae80eaf"
+
+PYPI_PACKAGE = "threadpoolctl"
+
+SRC_URI[md5sum] = "e278b89038d9c9b39e7afafb8f5f87a3"
+SRC_URI[sha256sum] = "a335baacfaa4400ae1f0d8e3a58d6674d2f8828e3716bb2802c44955ad391380"
+
+DEPENDS += "python3-flit-core python3-setuptools-native"
+
+inherit pypi setuptools3
+
+do_configure:prepend() {
+cat > ${S}/setup.py <<-EOF
+from setuptools import setup
+
+setup(
+ name="${PYPI_PACKAGE}",
+ version="${PV}",
+ license="${LICENSE}",
+)
+EOF
+}
+
+RDEPENDS:${PN} += "python3-flit-core"
+BBCLASSEXTEND = "native" \ No newline at end of file