summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb b/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
deleted file mode 100644
index 9fed3639..00000000
--- a/meta-offline-voice-agent/recipes-python/python3-threadpoolctl/python3-threadpoolctl_3.1.0.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-SUMMARY = "Python helpers to limit the number of threads used \
- in native libraries that handle their own internal threadpool"
-HOMEPAGE = "https://github.com/joblib/threadpoolctl"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8f2439cfddfbeebdb5cac3ae4ae80eaf"
-
-PYPI_PACKAGE = "threadpoolctl"
-
-SRC_URI[md5sum] = "e278b89038d9c9b39e7afafb8f5f87a3"
-SRC_URI[sha256sum] = "a335baacfaa4400ae1f0d8e3a58d6674d2f8828e3716bb2802c44955ad391380"
-
-DEPENDS += "python3-flit-core python3-setuptools-native"
-
-inherit pypi setuptools3
-
-do_configure:prepend() {
-cat > ${S}/setup.py <<-EOF
-from setuptools import setup
-
-setup(
- name="${PYPI_PACKAGE}",
- version="${PV}",
- license="${LICENSE}",
-)
-EOF
-}
-
-RDEPENDS:${PN} += "python3-flit-core"
-BBCLASSEXTEND = "native" \ No newline at end of file