summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb')
-rw-r--r--meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb b/meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
new file mode 100644
index 00000000..6e5a8f08
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-python/tiktoken/python3-tiktoken_0.7.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "tiktoken is a fast BPE tokeniser for use with OpenAI's models"
+HOMEPAGE = "None"
+AUTHOR = "Shantanu Jain <shantanu@openai.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3794f392e777e4fdf460d9bad404803"
+
+SRC_URI = "https://files.pythonhosted.org/packages/c4/4a/abaec53e93e3ef37224a4dd9e2fc6bb871e7a538c2b6b9d2a6397271daf4/tiktoken-0.7.0.tar.gz"
+SRC_URI[md5sum] = "62b4a9f1953826e61f8e09eb4a51965a"
+SRC_URI[sha256sum] = "1077266e949c24e0291f6c350433c6f0971365ece2b173a23bc3b9f9defef6b6"
+
+require ${BPN}-crates.inc
+
+S = "${WORKDIR}/tiktoken-0.7.0"
+
+DEPENDS += "python3-regex"
+
+RDEPENDS_${PN} = "python3-regex python3-requests python3-urllib3"
+
+inherit cargo setuptools3 python_setuptools3_rust cargo-update-recipe-crates
+
+