summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/recipes-whisper
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-07-03 17:28:05 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-08-30 11:53:02 +0000
commit8607d696eca482e025a9ca30ee992707211d1f11 (patch)
treeca4342a7db0465199119d1c24bf3e824a0f0a1c3 /meta-offline-voice-agent/recipes-whisper
parent65f1ec44778eaa59c2c74bf5fbb22a670b6231a0 (diff)
Integrate Whisper AI into AGL Voice Agent and Update Dependencies
V1: - Removed the following recipes from meta-offline-voiceagent: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - Updated to use meta-python-ai layer for: - python3-scipy - python3-scikit-learn - python3-openblas - python3-lapack - python3-numpy - python3-pytorch - Added all the required recipes for Whisper AI: - Included recipes for Whisper AI base and tiny model - Updated recipes for: - python3-uvloop - python3-python-crfsuite V2: - Remove vulkan from DISTRO_FEATURES as it has become coditional at upstream - Fix flutter_voiceassistant service - Update recipe of llvmlite to include the wheel for aarch64 also. V3: - Fix llvmlite recipe and some patches - Removes rasa and its dependencies - Fix agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: I429e7d4b98fbbe1a4f8c1341ac8918d7d177b382 Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/recipes-whisper')
-rw-r--r--meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-base.bb14
-rw-r--r--meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-tiny.bb15
-rw-r--r--meta-offline-voice-agent/recipes-whisper/whisper/whisper_git.bb18
3 files changed, 47 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-base.bb b/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-base.bb
new file mode 100644
index 00000000..42d75881
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-base.bb
@@ -0,0 +1,14 @@
+SUMMARY = "OpenAI Whisper base model"
+HOMEPAGE = "https://github.com/openai/whisper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${THISDIR}/../../licenses/LICENSE;md5=b1b8ea5cbbe899304ac6566613a3b74e"
+
+SRC_URI = "https://openaipublic.azureedge.net/main/whisper/models/ed3a0b6b1c0edf879ad9b11b1af5a0e6ab5db9205f891f668f8b0e6c6326e34e/base.pt"
+SRC_URI[sha256sum] = "ed3a0b6b1c0edf879ad9b11b1af5a0e6ab5db9205f891f668f8b0e6c6326e34e"
+
+do_install(){
+ install -d ${D}/usr/share/whisper
+ cp -R ${WORKDIR}/base.pt ${D}/usr/share/whisper/
+}
+
+FILES:${PN} = " /usr/share/whisper /usr/share/whisper/base.pt "
diff --git a/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-tiny.bb b/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-tiny.bb
new file mode 100644
index 00000000..19acc727
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-whisper/whisper-model/openai-whisper-tiny.bb
@@ -0,0 +1,15 @@
+SUMMARY = "OpenAI Whisper tiny model"
+HOMEPAGE = "https://github.com/openai/whisper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${THISDIR}/../../licenses/LICENSE;md5=b1b8ea5cbbe899304ac6566613a3b74e"
+
+SRC_URI = "https://openaipublic.azureedge.net/main/whisper/models/65147644a518d12f04e32d6f3b26facc3f8dd46e5390956a9424a650c0ce22b9/tiny.pt"
+SRC_URI[sha256sum] = "65147644a518d12f04e32d6f3b26facc3f8dd46e5390956a9424a650c0ce22b9"
+
+do_install(){
+ install -d ${D}/usr/share/whisper
+ cp -R ${WORKDIR}/tiny.pt ${D}/usr/share/whisper/
+}
+
+FILES:${PN} = " /usr/share/whisper /usr/share/whisper/tiny.pt "
+
diff --git a/meta-offline-voice-agent/recipes-whisper/whisper/whisper_git.bb b/meta-offline-voice-agent/recipes-whisper/whisper/whisper_git.bb
new file mode 100644
index 00000000..983999b5
--- /dev/null
+++ b/meta-offline-voice-agent/recipes-whisper/whisper/whisper_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Whisper AI - General-purpose speech recognition model"
+HOMEPAGE = "https://github.com/openai/whisper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b1b8ea5cbbe899304ac6566613a3b74e"
+
+SRC_URI = "git://github.com/openai/whisper.git;protocol=https;branch=main"
+SRCREV = "ba3f3cd54b0e5b8ce1ab3de13e32122d0d5f98ab"
+
+S = "${WORKDIR}/git"
+
+
+DEPENDS += "python3-wheel-native ffmpeg python3-numpy python3-pytorch python3-tqdm python3-tiktoken python3-more-itertools"
+
+inherit setuptools3 python3native
+
+RDEPENDS:${PN} += "ffmpeg python3-numba python3-regex python3-pytorch python3-tqdm python3-tiktoken"
+
+