summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-09-30 23:39:02 +0200
committerAnuj Solanki <anuj603362@gmail.com>2024-10-06 16:25:15 +0200
commit8949e1b030da7067da206a580c5124ca85ec9fbc (patch)
tree9eec1daea3ded33862a310aa66e83864acf8abc2 /meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb
parent1feb55631bea43bf7745921e247706303db4d6fc (diff)
Remove OpenAI's Whisper AI and its dependencies
- Remove OpenAI's Whisper AI recipes and all its dependencies. - Add recipes for whisper-cpp, whisper-cpp-base and whisper-cpp-tiny model. - Add recipe for python-mpd. - Add voice-agent-config to /etc/default and update config path in agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: Iaebd9c46930144b41659710202e9b737dbe9f60b Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb')
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb
new file mode 100644
index 00000000..42d75881
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper-model/openai-whisper-base.bb
@@ -0,0 +1,14 @@
+SUMMARY = "OpenAI Whisper base model"
+HOMEPAGE = "https://github.com/openai/whisper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${THISDIR}/../../licenses/LICENSE;md5=b1b8ea5cbbe899304ac6566613a3b74e"
+
+SRC_URI = "https://openaipublic.azureedge.net/main/whisper/models/ed3a0b6b1c0edf879ad9b11b1af5a0e6ab5db9205f891f668f8b0e6c6326e34e/base.pt"
+SRC_URI[sha256sum] = "ed3a0b6b1c0edf879ad9b11b1af5a0e6ab5db9205f891f668f8b0e6c6326e34e"
+
+do_install(){
+ install -d ${D}/usr/share/whisper
+ cp -R ${WORKDIR}/base.pt ${D}/usr/share/whisper/
+}
+
+FILES:${PN} = " /usr/share/whisper /usr/share/whisper/base.pt "