summaryrefslogtreecommitdiffstats
path: root/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper
diff options
context:
space:
mode:
authorAnuj Solanki <anuj603362@gmail.com>2024-09-30 23:39:02 +0200
committerAnuj Solanki <anuj603362@gmail.com>2024-10-06 16:25:15 +0200
commit8949e1b030da7067da206a580c5124ca85ec9fbc (patch)
tree9eec1daea3ded33862a310aa66e83864acf8abc2 /meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper
parent1feb55631bea43bf7745921e247706303db4d6fc (diff)
Remove OpenAI's Whisper AI and its dependencies
- Remove OpenAI's Whisper AI recipes and all its dependencies. - Add recipes for whisper-cpp, whisper-cpp-base and whisper-cpp-tiny model. - Add recipe for python-mpd. - Add voice-agent-config to /etc/default and update config path in agl-service-voiceagent.service Bug-AGL: SPEC-5200 Change-Id: Iaebd9c46930144b41659710202e9b737dbe9f60b Signed-off-by: Anuj Solanki <anuj603362@gmail.com>
Diffstat (limited to 'meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper')
-rw-r--r--meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper/whisper_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper/whisper_git.bb b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper/whisper_git.bb
new file mode 100644
index 00000000..983999b5
--- /dev/null
+++ b/meta-offline-voice-agent/unused-whisper-ai-recipes/recipes-whisper/whisper/whisper_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Whisper AI - General-purpose speech recognition model"
+HOMEPAGE = "https://github.com/openai/whisper"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b1b8ea5cbbe899304ac6566613a3b74e"
+
+SRC_URI = "git://github.com/openai/whisper.git;protocol=https;branch=main"
+SRCREV = "ba3f3cd54b0e5b8ce1ab3de13e32122d0d5f98ab"
+
+S = "${WORKDIR}/git"
+
+
+DEPENDS += "python3-wheel-native ffmpeg python3-numpy python3-pytorch python3-tqdm python3-tiktoken python3-more-itertools"
+
+inherit setuptools3 python3native
+
+RDEPENDS:${PN} += "ffmpeg python3-numba python3-regex python3-pytorch python3-tqdm python3-tiktoken"
+
+