aboutsummaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/conf/include
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-15 20:37:40 -0400
committerScott Murray <scott.murray@konsulko.com>2019-12-20 15:44:08 -0500
commit51b5717e14a9286dc335f601f2830827625f1d67 (patch)
tree6dc9049ef892ecdb9adc4bf0dc16dfdeb5f05e9e /meta-speech-framework/conf/include
parent3d6edba9fc888d4c6a02453dc44c047a665ec59c (diff)
meta-speech-framework: rework voiceagent configuration
After agl-service-voice-high rework to make the voiceagent(s) used externally configurable, replace the previous virtual/voiceagent PREFERRED_RPROVIDER scheme with a virtual/voice-high-config that just selects the appropriate configuration package based on the specified feature. If agl-speech-framework is specified on its own, a default configuration file specifying no default voiceagent will be installed. If agl-voiceagent-alexa is specified, the default configuration will specify the Alexa voiceagent as the default. Recipes have been added for the new configuration file packages, and the alexa-voiceagent-service recipe has been tweaked to create a package with the Alexa per-voiceagent configuration file and add it as a dependency. Bug-AGL: SPEC-2898 Change-Id: I3ea2534b0f55aefa0226ef09b6ffde468feef2fe Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit a765be206e7379885c8df72f4ff89b6e0bf14e1e)
Diffstat (limited to 'meta-speech-framework/conf/include')
-rw-r--r--meta-speech-framework/conf/include/agl-speech-framework.inc3
-rw-r--r--meta-speech-framework/conf/include/agl-voiceagent-alexa.inc2
2 files changed, 2 insertions, 3 deletions
diff --git a/meta-speech-framework/conf/include/agl-speech-framework.inc b/meta-speech-framework/conf/include/agl-speech-framework.inc
index 9b7a0f07..ee19d25f 100644
--- a/meta-speech-framework/conf/include/agl-speech-framework.inc
+++ b/meta-speech-framework/conf/include/agl-speech-framework.inc
@@ -1,2 +1 @@
-# Currently no default voiceagent
-PREFERRED_RPROVIDER_virtual/voiceagent ?= ""
+PREFERRED_RPROVIDER_virtual/voice-high-config = "default-voice-high-config"
diff --git a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
index ad509d14..7b478474 100644
--- a/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
+++ b/meta-speech-framework/conf/include/agl-voiceagent-alexa.inc
@@ -3,4 +3,4 @@
# agl-voiceagent-alexa is configured.
BBMASK += "meta-aac/recipes-support/curl/curl_%.bbappend"
-PREFERRED_RPROVIDER_virtual/voiceagent = "alexa-voiceagent-service"
+PREFERRED_RPROVIDER_virtual/voice-high-config = "alexa-voice-high-config"