summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-08 13:23:42 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-02-05 14:56:52 +0000
commit8bf3c50ab7eb48f8db63ea41d6a12e32f3633dee (patch)
treeacf5541f19ca2a40ef1361e0757485d91e0b05c6 /meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
parentd369fae7ef2e0bcbd934c838145b08a443b414ff (diff)
Changes: - Mask out the duplicate libopus recipe, the same version is available from a recipe in meta-oe. - Update BBFILES addition for the audio module in the feature template to work with yet another new audio output backend. - Update the AlexaAutoCoreEngineConfig.json.in template based on the new sample JSON in 2.3. - Update alexa-voiceagent-config recipe to add new configuration variables ALEXA_LOCALE, ALEXA_TIMEZONE, ALEXA_MFG_NAME, and ALEXA_DESCRIPTION to match requirements of the updated configuration JSON. - Remove local alexa-voiceagent-service patches merged by Amazon, and update 0001-remove-library-dependency-copying.patch for 2.3. - Update SDK module DEPENDS for alexa-voiceagent-service recipe to match what seems required now with 2.3. - Remove avs-device-sdk patch for building with g++ 9.x, as it is no longer required. - Add avs-device-sdk patch to workaround hang seen on first connection. - Add bbappends for aac-module-car-control and aac-module-messaging recipes to fix their nlohmann-json DEPENDS to work with the recipe that is available in meta-oe. - Rework aac-module-system-audio.bbappend to enable the PipeWire support that has been merged into the module. Bug-AGL: SPEC-3783 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I18c910f9cbf874fef85d1d84508f6666d53629ed (cherry picked from commit e0d5ad833e89f47c88601e15158015319e568af8)
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb39
1 files changed, 25 insertions, 14 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
index 7e5992bb..a16ad182 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
@@ -11,30 +11,41 @@ SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
inherit allarch
ALEXA_WAKEWORD ??= "false"
+ALEXA_LOCALE ??= "en-US"
+ALEXA_TIMEZONE ??= "America/Vancouver"
-do_compile () {
+do_compile[noexec] = "1"
- if test x"${ALEXA_CLIENTID}" == x"" ; then
- bbfatal "ALEXA CLIENTID not defined in your environment e.g. conf/local.conf"
+do_install () {
+ if [ -z "${ALEXA_CLIENTID}" ]; then
+ bbfatal "ALEXA_CLIENTID not defined in your environment e.g. conf/local.conf"
fi
-
- if test x"${ALEXA_SERIALNUMBER}" == x"" ; then
- bbfatal "ALEXA SERIALNUMBER not defined in your environment e.g. conf/local.conf"
+ if [ -z "${ALEXA_SERIALNUMBER}" ]; then
+ bbfatal "ALEXA_SERIALNUMBER not defined in your environment e.g. conf/local.conf"
fi
-
- if test x"${ALEXA_PRODUCTID}" == x"" ; then
- bbfatal "ALEXA PRODUCTID not defined in your environment e.g. conf/local.conf"
+ if [ -z "${ALEXA_PRODUCTID}" ]; then
+ bbfatal "ALEXA_PRODUCTID not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_MFG_NAME}" ]; then
+ bbfatal "ALEXA_MFG_NAME not defined in your environment e.g. conf/local.conf"
+ fi
+ if [ -z "${ALEXA_DESCRIPTION}" ]; then
+ bbfatal "ALEXA_DESCRIPTION not defined in your environment e.g. conf/local.conf"
fi
-}
-
-do_install () {
#replace
- sed -e "s/@@ALEXA_CLIENTID@@/${ALEXA_CLIENTID}/" -e "s/@@ALEXA_SERIALNUMBER@@/${ALEXA_SERIALNUMBER}/" -e "s/@@ALEXA_PRODUCTID@@/${ALEXA_PRODUCTID}/" -e "s/@@WAKEWORD@@/${ALEXA_WAKEWORD}/" ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
+ sed -e "s|@@ALEXA_CLIENTID@@|${ALEXA_CLIENTID}|" \
+ -e "s|@@ALEXA_SERIALNUMBER@@|${ALEXA_SERIALNUMBER}|" \
+ -e "s|@@ALEXA_PRODUCTID@@|${ALEXA_PRODUCTID}|" \
+ -e "s|@@ALEXA_MFG_NAME@@|${ALEXA_MFG_NAME}|" \
+ -e "s|@@ALEXA_DESCRIPTION@@|${ALEXA_DESCRIPTION}|" \
+ -e "s|@@ALEXA_WAKEWORD@@|${ALEXA_WAKEWORD}|" \
+ -e "s|@@ALEXA_LOCALE@@|${ALEXA_LOCALE}|" \
+ -e "s|@@ALEXA_TIMEZONE@@|${ALEXA_TIMEZONE}|" \
+ ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
# install
install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json
}
RPROVIDES_${PN} += "virtual/alexa-voiceagent-config"
-