summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-10-18 14:24:52 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-11-04 14:24:38 +0000
commite345e16bb494864caf1f7dbe8864aa40df401a70 (patch)
treec309d39646f3e796344cc68081f5bff48cf63e2c /meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
parent796e9aefb7eee0fc7526e5613a03bc7f6697cef4 (diff)
Prepare master for new framework integration
During the last workshop the transition to the new framework was presented. This change essentially deprecates the SMACK-based application framework. To prepare the integration of it, we remove the deprecated components: - meta-speech-framework and the voiceagent services Bug-AGL: SPEC-4121 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I803dd18184338a1f5519af27136e1d5a58ee9369
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
deleted file mode 100644
index 13d259b8..00000000
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-config_1.0.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-SUMMARY = "Alexa service binding default configuration to connect to Alexa"
-DESCRIPTION = "Alexa alexa-voiceagent-service binding configuration files"
-HOMEPAGE = "https://github.com/alexa/alexa-auto-sdk/tree/master/platforms/agl/alexa-voiceagent-service"
-SECTION = "apps"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-
-SRC_URI = "file://AlexaAutoCoreEngineConfig.json.in"
-
-inherit allarch
-
-ALEXA_WAKEWORD ??= "false"
-ALEXA_LOCALE ??= "en-US"
-ALEXA_TIMEZONE ??= "America/Vancouver"
-
-do_compile[noexec] = "1"
-
-do_install () {
- if [ -z "${ALEXA_CLIENTID}" ]; then
- bbfatal "ALEXA_CLIENTID not defined in your environment e.g. conf/local.conf"
- fi
- if [ -z "${ALEXA_SERIALNUMBER}" ]; then
- bbfatal "ALEXA_SERIALNUMBER not defined in your environment e.g. conf/local.conf"
- fi
- if [ -z "${ALEXA_PRODUCTID}" ]; then
- bbfatal "ALEXA_PRODUCTID not defined in your environment e.g. conf/local.conf"
- fi
- if [ -z "${ALEXA_MFG_NAME}" ]; then
- bbfatal "ALEXA_MFG_NAME not defined in your environment e.g. conf/local.conf"
- fi
- if [ -z "${ALEXA_DESCRIPTION}" ]; then
- bbfatal "ALEXA_DESCRIPTION not defined in your environment e.g. conf/local.conf"
- fi
-
- #replace
- sed -e "s|@@ALEXA_CLIENTID@@|${ALEXA_CLIENTID}|" \
- -e "s|@@ALEXA_SERIALNUMBER@@|${ALEXA_SERIALNUMBER}|" \
- -e "s|@@ALEXA_PRODUCTID@@|${ALEXA_PRODUCTID}|" \
- -e "s|@@ALEXA_MFG_NAME@@|${ALEXA_MFG_NAME}|" \
- -e "s|@@ALEXA_DESCRIPTION@@|${ALEXA_DESCRIPTION}|" \
- -e "s|@@ALEXA_WAKEWORD@@|${ALEXA_WAKEWORD}|" \
- -e "s|@@ALEXA_LOCALE@@|${ALEXA_LOCALE}|" \
- -e "s|@@ALEXA_TIMEZONE@@|${ALEXA_TIMEZONE}|" \
- ${WORKDIR}/AlexaAutoCoreEngineConfig.json.in > ${WORKDIR}/AlexaAutoCoreEngineConfig.json
-
- # install
- install -D -m 644 ${WORKDIR}/AlexaAutoCoreEngineConfig.json ${D}${sysconfdir}/xdg/AGL/AlexaAutoCoreEngineConfig.json
-}
-
-RPROVIDES:${PN} += "virtual/alexa-voiceagent-config"