summaryrefslogtreecommitdiffstats
path: root/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-10-15 20:37:40 -0400
committerScott Murray <scott.murray@konsulko.com>2019-12-20 15:44:08 -0500
commit51b5717e14a9286dc335f601f2830827625f1d67 (patch)
tree6dc9049ef892ecdb9adc4bf0dc16dfdeb5f05e9e /meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
parent3d6edba9fc888d4c6a02453dc44c047a665ec59c (diff)
meta-speech-framework: rework voiceagent configuration
After agl-service-voice-high rework to make the voiceagent(s) used externally configurable, replace the previous virtual/voiceagent PREFERRED_RPROVIDER scheme with a virtual/voice-high-config that just selects the appropriate configuration package based on the specified feature. If agl-speech-framework is specified on its own, a default configuration file specifying no default voiceagent will be installed. If agl-voiceagent-alexa is specified, the default configuration will specify the Alexa voiceagent as the default. Recipes have been added for the new configuration file packages, and the alexa-voiceagent-service recipe has been tweaked to create a package with the Alexa per-voiceagent configuration file and add it as a dependency. Bug-AGL: SPEC-2898 Change-Id: I3ea2534b0f55aefa0226ef09b6ffde468feef2fe Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit a765be206e7379885c8df72f4ff89b6e0bf14e1e)
Diffstat (limited to 'meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb')
-rw-r--r--meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
index 689e9d53..40a9185d 100644
--- a/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
+++ b/meta-speech-framework/meta-aac/recipes-apis/alexa-voiceagent-service/alexa-voiceagent-service_git.bb
@@ -20,6 +20,7 @@ DEPENDS = " \
"
SRC_URI = "git://github.com/alexa/alexa-auto-sdk.git;protocol=https;branch=2.0 \
+ file://alexa.json \
file://0001-remove-library-dependency-copying.patch \
file://0002-update-config.xml.in.patch \
file://0003-update-audio-device-configuration.patch \
@@ -35,10 +36,14 @@ inherit cmake aglwgt
EXTRA_OECMAKE += "-DAAC_HOME=${RECIPE_SYSROOT}/${AAC_PREFIX}"
-# NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
-# core module
-RDEPENDS_${PN} += "libcurl libopus libsqlite3"
+do_install_append() {
+ install -D -m 0644 ${WORKDIR}/alexa.json ${D}${sysconfdir}/xdg/AGL/voiceagents/alexa.json
+}
+
+PACKAGES =+ "${PN}-conf"
-RPROVIDES_${PN} += "virtual/voiceagent"
+FILES_${PN}-conf = "${sysconfdir}/xdg/AGL/voiceagents/*"
-RDEPENDS_${PN} += "virtual/alexa-voiceagent-config"
+# NOTE: curl and opus are from the base SDK libraries, sqlite3 from the
+# core module
+RDEPENDS_${PN} += "libcurl libopus libsqlite3 ${PN}-conf"